Todoist loading forever / can't sign in / not working

📦station-v1-17-x
✅released

(Sandro M.) #1

The issue I’m facing is that the Todoist extension is not loading. Works normally in the browser. Works in another (Mac) Station. Does not work in my Windows machine. Removed Todoist from Station, reinstalled, nothing.


Here’s the detailed report

  • Trigger: Todoist extension
  • Issue: “Loading” image stays forever, Todoist does not load
  • Explanatory gifs/pictures (we really need that :pray: )
    Capturar
  • OS version: Windows 10 Pro version 1709
  • Station version: 1.9.0

Todoist Added - But Can't Sign In
Cannot sign in to Todoist without workaround
Todoist not working after log out
Todoist not loading
(Brian W) #2

I have the same issue - it’s worked fine 2-3 weeks ago


(Tom Whatley) #3

The issue I’m facing is … getting the following error message when trying to load Todoist:

image


Here’s the detailed report

  • Trigger: Opening Todoist in Station
  • Issue: See image above
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Windows 10
  • Station version: 1.9.0

(Joe O'connell) #4

Todoist was acting odd with the labels. As I have been told in the past by Todoist, I logged out.

When I went to log back in the page wouldn’t load. I entered my credentials and clicked log in and nothing happened.

Here’s the detailed report

  • Trigger: Log in to Todoist
  • Issue: Not loading
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Windows 10
  • Station version: 1.9.0

(Joe O'connell) #5

screen shot of the page not loading.


(Simon Smith) #6

The issue I’m facing is: When I try to log in to Todoist, nothing happens. I install Todoist, click “log in” on the Todoist site, and then click to sign in with my Google account. But nothing happens. The Google account sign in screen won’t open.

For others facing this issue, I found a workaround:

  1. Install Todoist
  2. Open Todoist in Station
  3. In the Todoist website header, right click “log in”
  4. Choose “open in new page”
  5. This should open the Todoist login popup in its own page
  6. Sign in with your Google account
  7. Now click on the Todoist icon in Station and go back to the Todoist home page
  8. Now click “open web app” in the header of the Todoist site

(Some of the names of the links may be different as described here as I’m currently logged in and don’t remember the exact details.)

The bottom line is that there seems to be some kind of issue opening the Google account sign in page from the Todoist login popup, but you can get around it by opening the popup in its own page.


Here’s the detailed report

  • Trigger: Install Todoist app, click “log in” on Todoist website, click to log in with Google account
  • Issue: Nothing happens; should take you to Google account login screen, but does not
  • OS version: Mac OS High Sierra v10.13.5
  • Station version: 1.15.1

(Georges Abi-Heila) #7

Hey everyone :wave:

This should be fixed in Station’s version 1.17.
Could you update your Station then remove / re-add Todoist and tell us if it’s been solved for you?

To update, just open the preferences (from the top bar menu) and click the “Check for updates” button on the right.


(Jeremy B) #8

:writing_hand: Brief description of the issue

The todoist app is able to be added, but when we click on Google Sign-in then nothing happens.


:warning: Mandatory details