Station won't launch but appears in the task manager / processes are running but nothing happens / I can't see the main window / can't bring Station to the foreground

📦station-v1-30-x
✅released

(Michael Liang) #42

The issue I’m facing is that the windows version of Station seem to open reliably. The app works once in a blue moon but 90% of what happens is that it loads but never opens (I can see a preview when I hover over the icon in the windows 10 task bar).


Here’s the detailed report

  • Trigger: opening the app

  • Issue: app window not appearing

  • Explanatory gifs/pictures (we really need that :pray: ):image

  • OS version: Windows 10 Enterprise Version 10.0.16299 Build 16299

  • Station version: 1.0.13.0


(Blair) #43

@Alexandre I deleted that last week and it hasn’t returned. I no longer have a “Station” folder in my Application Support. Anything else I can try?


(Movin Jain) #44

:writing_hand: Brief description of the issue
Station doesn’t launch at all on Mac. I can see processes running, but there’s no window!

My problem is that …
I can’t use Station


:warning: Mandatory details

  • :gun: Trigger
    I quit and restarted station because Slack was not getting refreshed.

  • :boom: Issue
    When I open Station, the window doesn’t launch. It’s as if everything is fine but the window is not there!

  • :movie_camera: Explanatory gifs/pictures
    https://imgur.com/a/WukVNMz

  • :desktop_computer: OS version
    Mac OS Mojave 10.14.2 Beta

  • :gear: Station version
    1.29.0


#45

I have this same issue.


(Bart V) #46

Same issue as well :frowning:
Loving the program - can’t use it at all anymore…


(Georges Abi-Heila) #47

Hey @Bart_Vossen, @ememem, @movinjain, @Blair_Feehan, @Michael_Liang, @Fabricio_Medeiros, @eloypnd, @Adrien_Flixup, @I_heart_AV, @Luca, @sihil, @Gary_O_Connor, @krschacht, @Jonathan_Garvey, @cclark, @bleeisblee, @Michael_Clinton, @Victor_Hernandez, @pnicolli, @peterjuras, @Nicolas_Ottero, @BoChen, @B_H, @Abdallah_Fakry, @renevranc, @Hernan_Herrera_Hall, @Roberto_Vitali, @rccolata, @Andreas_Wagner, @SAEcheverri :wave:

This should be fixed in Station’s latest version (1.30.0) :partying_face:
Could you update your Station and tell us if it’s been solved for you?

To update, just open the preferences (from the “Station” top bar menu) and click the “Check for updates” button on the right.

Edit: we are working on a second version of the fix introduced in version 1.30.0 that should catch more cases.


(Colin Sygiel) #48

:writing_hand: Brief description of the issue

When opening the Station Mac app, nothing loads except for the toolbar options like “Station, Edit, View, etc.”. Nothing happens after tapping on “Reset Current Application.” Re-installing and resetting mac does not help as well.


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — 10.14.1

  • :gear: Station version — 1.3


#49

I have the exact same issue with same versions (Station 1.3 & Mojave 10.14.1). Even uninstall/install back did not solve the issue :frowning:


(Alexandre Lacheze) #50

@lamathan @Colin_Sygiel 'm not sure to understand with what version you are experiencing the issue. Can you make sure you are on version 1.30.0

If not working, can you copy paste the content of ~/Library/Application\ Support/Station/window-state.json here, please?


(Luca) #51

I resolved removing ~/Library/Application\ Support/Station/window-state.json

I’ll keep you updated if the issue appears again


#52

The JSON : {“width”:1433,“height”:877,“x”:0,“y”:1283,“displayBounds”:{“x”:0,“y”:0,“width”:1440,“height”:900},“isMaximized”:true,“isFullScreen”:false}

As well my station version

As Luca just wrote, deleting the json file seems to solve the issue. All back now :partying_face:


(Alexandre Lacheze) #53

@lamathan @Luca thanks! We are working on a 2nd version of the fix that should be out in the week.


#54

Same issue. I stopped using station after it wouldn’t display anything in MacOs. I tried reinstalling it, not succes,

Before that, it used to launch but only when I was at work???

Now it no longer launches at all. (appears in the launcher but no window)


(Luca) #55

@Alexandre

I just open Station, and as you may know, the issue persists with version 1.30.0

As always, deleting rm ~/Library/Application\ Support/Station/window-state.json solve it.

P.S. I’m using macOS. For the next time (and if it appears again), do you need my window-state.json?

[UPDATE 29 nov]
The issue persists. Here are both files, the broken and working windows-state ones

window-state.broken.json (197 Bytes)
window-state.working.json (171 Bytes)


(Pijuli) #56

Still happening. Deleting the file seems to work, though…


(Alexandre Lacheze) #57

@Pijuli @Luca @Y.E @lamathan

Can you try with the latest version of Station (1.31.0) please?

Note there is now a menu Window > Reset Position on MacOS in the menu bar.


(Jaymie Friesen) #58

:writing_hand: Brief description of the issue

The app won’t open. When I click on the icon in my dock it show’s Station on the top left of my screen, but the actual app does not show up. Cannot find the page anywhere even when I “show all windows”. Still get notifications though, but they don’t open the app. It’s like it’s just invisible.


:warning: Mandatory details

  • :gun: Trigger — Not sure, I closed it and then it started doing this.

  • :boom: Issue — App went invisible basically.

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — MacBook Pro, MacOS Mojave, Version 10.14.1

  • :gear: Station version — 1.30.0


#59

That wooorks!!

I relaunched Station today (at work) and the window appeared.

I did the 1.31.0 update (from inside Station), restarted and still working.

I’ll test at home to confirm the resolution on my side.


#60

Tested at home, it works! All good on my side.

Keep up the good work!


(Ella Ding) #61

Hi, I have the same problem, could you tell me how to solve it in windows? Thanks