Station won't launch but appears in the task manager / processes are running but nothing happens / I can't see the main window / can't bring Station to the foreground

📦station-v1-30-x
✅released

(Bryant Lee) #22

Hey everyone,

Yesterday I restarted my mac, and Station just stopped working. It is running on the system, and I can see it in the tray, however the UI never draws, and I cant see anything.

I have removed it, reinstalled it via brew, reinstalled it via the site, nothing working.

Any ideas here?


(Victor Hernandez) #23

Same issue. Running in Mac OS Mojave 10.14.

I’ve cleaned up all temp files for apps I’m currently using on Station, restarted the system, not yet reinstalled, but all to no avail.

Eager for suggestions or resolution.

Thanks!


(Victor Hernandez) #24

Update…

I use my Mac with two external monitors. When I last used Station (two days ago) Station was displaying on one of the external monitors. When using the laptop by itself today, Station launched, but as noted by @bleeisblee , though the process is running, it would not display on the screen.

After connecting to the external monitors, there it is, where I last left it. There seems to be at least one related bug to this - Station ‘remembering’ last external monitor on which it was used, and not displaying for the main/default laptop screen when not connected to the external monitors.


(Michael Clinton) #25

@Alexandre are you all aware of this?

I just updated and am using Mojave as well. App is not drawing for me either, even ran a script to force it to the center of my screen and did not work.


(Bryant Lee) #26

Just got back from a work trip, and sure enough, hooking up my second monitor and Station is back.


(Chuck Clark) #27

:writing_hand: Brief description of the issue

My problem is that …
I start Station and a main application window does not appear. I can click Window -> Bring all to front and nothing appears. View -> Process Manager shows a bunch of processes running including one of Process Type Browser which I think is the main thread. But I can’t see the main application. I can see the About window. So it only seems to be the main application window that is impacted.

This is on macOS. I have restarted Station without luck. I have also rebooted macOS but still do not have a main app window.


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue
    The driver for quitting Station was that I had the Station Helper app running crazy and consuming 400%+ of CPU according to Activity Monitor. I stopped the app figuring it was some sort of runaway process. Now I no longer have a main application window.

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — macOS 10.14

  • :gear: Station version — 1.26.0


(Chuck Clark) #28

I wasn’t using multiple monitors but the trick of running
rm ~/Library/Application\ Support/Station/window-state.json
worked for me. I’m back up and running now and will see if the high CPU state kicks in that seemed to be somehow related to this triggering for me.


(Jonathan Garvey) #29

@Alexandre
I had the same issue on macOS Mojave (10.14) and Station 1.26.
Using rm ~/Library/Application\ Support/Station/window-state.json worked for me as well.


(Keith Schacht) #30

This morning I’m sitting down to start my day and I accepted the notification asking me to upgrade to the latest Station. After I did, Station has completely disappeared.

The application is clearly running. I’m getting notifications. But I’m not able to bring Station to the foreground on my Mac so I can actually see it!

I’ve uninstalled and re-downloaded and re-installed the latest version. Can you help? Here is a screen recording so you can see what I mean:

CloudApp


(Gary O'connor) #31

:writing_hand: Brief description of the issue

My problem is that when I download the latest version of station 1.26.0, I cannot open the app once it has installed. The program appears to install as expected.

Once the application file is clicked, nothing appears to happen and the program does not start.
This happens when run normally and as administrator.


  • :boom: Issue
    The application won’t launch

  • :movie_camera: Explanatory gifs/pictures
    image
    Click run as administrtor or just double click shortcut.

nothing launches
image

multiple child processes are running but nothing has launched

  • :desktop_computer: OS version — Windows 10

  • :gear: Station version 1.26.0


(Simon) #32

I have exactly the same thing as @krschacht. Restarting station has resulted in no longer being able to see the main window.

As per @cclark deleting ~/Library/Application\ Support/Station/window-state.json and restarting again solved the problem.


(Luca) #33

Awesome, it works for me!! thanks!


#34

:writing_hand: Brief description of the issue

In a recent update with Station (can’t remember when) the app works great in full screen. When not set full screen, there is no window or interface.


:warning: Mandatory details


#35

For Windows 10 I solved it this morning by following the logic of the thread:

  1. I closed Station

  2. I went to %USERPROFILE% folder -> AppData -> Roaming -> Station

  3. I then nuked the “window-state.json” file

  4. Run station, works as it should again!

So I guess bug now is: How to prevent from happening in the future.


(Alexandre Lacheze) #36

I was able to reproduce this bug on Mac with Station 1.28.1:

  • have Station on the 2nd screen in full-mode
  • quit Station
  • unplug 2nd screen
  • re-open Station (Station opens in full-screen mode)
  • quit the full-screen mode
  • => the window is invisible (outside of screen)

(Adrien Caïazzo) #37

Thanks a lot! It worked for me


(Blair) #38

I’m having the same issue when booting Station on my Mac laptop after using a second monitor earlier this week. I’ve tried deleting ~/Library/Application\ Support/Station/window-state.json and lots of rebooting to no avail. This happens consistently for me, and I miss Station when I can’t use it whenever I work from home. So glad to hear you’ve been able to replicate the issue. Are there any other fixes I can try, or plans to release a fix in an upcoming update?


(Alexandre Lacheze) #39

@Blair_Feehan can you copy paste the content of ~/Library/Application\ Support/Station/window-state.json here please?


(Eloy Pineda) #40

:writing_hand: Brief description of the issue

My problem is that I can’t use Station at all because there is no window, even though the app looks like it is open.


:warning: Mandatory details

  • :gun: Trigger

Security update on macOS High Sierra

  • :boom: Issue

App unusable

  • :movie_camera: Explanatory gifs/pictures

42
21

  • :desktop_computer: OS version

macOS High Sierra 10.13.6

  • :gear: Station version

Stationversion 1.29.0
Electron3.0.5
Chrome66.0.3359.181
Node10.2.0
v86.6.346.32
@getstation/services0.23.2


(Fabricio Medeiros) #41

Suddenly Station opens but no window is shown. I am using mac mojave. I am able to use the menu but no option gives a response. I don’t even have the bar on the left, simply no window at all just the top bar menu. I removed Station form applications, download the latest version and installed but same results.