Station freezes when receiving a notification / Google Calendar keeps hanging

Thanks for telling us there is a problem with your Station
but you just forgot to provide the following:
:warning: Mandatory details

  • :gun: Trigger
  • :boom: Issue
  • :movie_camera: Explanatory gifs/pictures
  • :desktop_computer: OS version
  • :gear: Station version

Could you please provide us with these details.

:writing_hand: Brief description of the issue

My problem is that Google Calendar freezes when I click on it after using other tabs for a while. Unable to click on any of the items on my agenda.

:warning: Mandatory details

  • :gun: Trigger — Switching to the tab via mouse click.

  • :boom: Issue — When I open it in a separate window, it unfreezes

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Mojave

  • :gear: Station version — Stationversion 1.26.0 | Electron3.0.2 | Chrome66.0.3359.181 | Node10.2.0 | v86.6.346.32

@Eugen_GOSSEN @Kalyan_Varma @chandadiane
We are working on fixing the issue, and it should be released tomorrow.

In the meantime, there is a small workaround: in Calendar settings, change notifications from “Interruptive alerts” to “Browser notifications”. We are explaining a similar manoeuvre here.

Same problem here with google calendar.

After the Station update, google calendar’s keyboard shortcuts are no longer working.

There is an update of Station.
Could you update your Station to the newest update and see if you still have the same problem?

Let us know if it helps :wink:

@DevBytes Indeed, everything is working again with Station-1.27.1!

(Meanwhile, I’ve also suffered a Windows crash in the mean time and have started from a fresh Windows install, so I’m not sure if there are other variables at play, but it’s working now, anyway.)

Thanks for fixing!

Good to hear that it’s solved in Station-1.27.1

everything is still stuck with 1.27.1 on windows 7
the problem does not exists with 1.25.1

@DevBytes can you test on windows 7?

1 Like

Last working version was 1.25.

1.26 and 1.27 will “load” forever. When it finally does, it won’t let me delete emails, check slack or any other app.

Is there a way to prevent an auto-update?

It’s so frustrating since everytime it auto updates, I have to do a clean uninstall and then setup 1.25 all over again (By the 4th time you begin to lose hope…)

Hi @maximd ,
Ill check this evening.
i’ll let you know what i find. :wink:

Hi @DevBytes, did you find some time to test on windows 7?

@Rosebudd could you tell us which OS you are using?

No sorry i already updated to 1.28.1.
Everything seems to work fine on windows 10 with 1.28.1

@DevBytes: the problem persists on with 1.28.1 on windows 7 pro 64 bits (which is not really an uncommon OS version): everything is slow and some the applications even fail to load (like gmail which would just not succeed to connect with an error message). This is true even after clicking on “Reset Current Application” for every app.

And I discovered that even after deleting %APPDATA%\Station (to have a vanilla installation), station 1.28.1 is really slow even to just display it’s first login page (where you put your email address to be able to use station). So there’s really something wrong beginning with 1.26.0 (which, as a reminder, is a version that uses a new version of electron which was upgraded to 3.0).

As a simple summary:

  • station 1.25.1 (electron 2.0.2) on windows 7 pro 64 bits: everything smooth
  • station 1.26.0 and later (electron 3.0) on windows 7 pro 64 bits: everything is slow, there are timeouts in apps (like gmail), most apps simply never load. Even with a vanilla profile (= remove %APPDATA%\Station), station is really slow (more than 10 seconds) to load the first login form.

It would be great if you could test it on your side on windows 7 because that’s where a doubt remains (as you explained, it works fine on windows 10).

Or is there someone else that could/should do the test (no offense @DevBytes but it is in fact not clear whether you work for station or not by looking at you station community’s profile :slightly_frowning_face:). Maybe @Alexandre is the right person to ask?

In the meantime I reinstall 1.25.1 everytime I close station or reboot my computer to be able to work. I don’t mind doing it because station is a good piece of software that helps me being organized in my everyday work. But I certainly hope that this problem will be properly tested on windows 7 on your side.

1 Like

@DevBytes Is there a way to simply block auto updates? Just like the user above, on Windows 7 everything is super smooth up until 1.25… i tried all versions since and they don’t work at all on W7.

1 Like

@Rosebudd what version are you on right now? Version 1.25?
Maybe it would be a good idea to try out the newest version “1.30.0”.

@maximd I do not work for station! I’m just a user who is trying to help where I can.
I didn’t think someone would think that i worked for station :joy: But thanks i guess.
You can check if people work for station by looking for the shield icon in their name, checking if the Trust level is Leader or if they are in the group: Moderators.


@DevBytes It keeps auto updating so I’m on the latest one… which simply doesn’t work. All I want is to block auto updates, 1.25 worked flawlessly there was absolutely no need for any updates

I never had the need to disable auto update.
i didn’t even know there was an auto update implemented and always clicked update as soon as i saw the update button appear to see what changes would be made.
For now i don’t know of a way to turn it off.
Let’s hope the next update fixes things for you.

1 Like

Hey @maximd,

This bug has been fixed since Station 1.27 release… except on Windows 7 apparently where you and other users (hey @Rosebudd :wink: ) have reported persisting issues.

Unfortunately, we don’t plan to:

  • Give the option to block auto-updates → Having a homogenous user-base with an up-to-date Station is a huge asset (facilitates support, onboarding, communication & testing)
  • Add Windows 7 to our Quality Assurance process → Windows 7 is an obsolete OS that’s nearly 10 years old, and whose support will soon be discontinued by Microsoft.

Have you considered updating your OS?
We understand it can be a hassle but there’s not much we can do for the moment as we prioritise improvements that affect a higher % of our user-base.