Station Fatal Error

:writing_hand: Brief description of the issue

My problem is that …

Hi there, been using Station for a while and it’s amazing. Booted up my laptop today and all of a sudden, Station doesn’t work anymore. Didn’t change any settings and it comes up with a fatal error.

It comes up with the following:

error:1e000065:Cipher functions:OPENSSL_internal:BAD_DECRPYT

Could I get help with this? Thanks


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

  • :gear: Station version

Yup, I’m getting the exact same error.
I would be grateful if this error is fixed ASAP, please.

:writing_hand: Brief description of the issue

After updating to the latest version, no matter how I launch the appimage file (with launcher or oneshot), I get this error (see image).


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures
    S%C3%A9lection_003

  • :desktop_computer: OS version
    Ubuntu 18.04.3 LTS

  • :gear: Station version
    1.58.1 &1.57.1

Hello @normanchella, @Vinay_Kumar, @PAL

Thank you for reporting this bug, we looked into it and our tech team is working on a fix that will be released in the beginning on next week. In the meantime, we have a workaround for you each time you want to open Station. Try this instructions, and tell us how it goes.

  1. Quit Station

  2. Download SQlite for your platform:

  1. Decompress the downloaded zip, and open a Terminal/Console

  2. Execute the following statement, depending on your OS:

  • Mac: cd <extracted-folder-path> && chmod +x ./sqlite3 && ./sqlite3 ~/Library/Application\ Support/Station/db/station.db "DELETE FROM "authToken";"

  • Windows: <extracted-folder-path>/sqlite3.exe %appdata%/Station/db/station.db "DELETE FROM "authToken";"

  • Linux: cd <extracted-folder-path> && chmod +x ./sqlite3 && ./sqlite3 ~/.config/Station/db/station.db "DELETE FROM "authToken";" (edited)

it’s not working on macOS Catalina 10.15.1 :

Hi @Stefan_Irava,

Try going to Mac Settings > Security & Privacy > General
There, while you are trying to open “sqlite3”, you will have an option to allow the program to work anyway.

Tell me if it works!

Hi @Maud

Yep, it worked, thanks a lot! And Station is working now.

1 Like

So before finding this thread, I tried uninstalling Station and reinstalling, but now I get the error message as I’m trying to re-install - and that fix above with SQlite can’t find the file (presumably deleted with the uninstall?) Help!

Hello @normanchella, @Vinay_Kumar, @PAL, @Stefan_Irava, @Aaron_Guthrie,

We released an update to fix this issue. Tell me all how it goes for you!

Hey there Maud, cheers for the update. Had to redownload the installer as the initial SQLite solution didn’t work. I assumed the new installer on the website came with the update, and it worked!

1 Like

Hi Maud,

Your SQL solution worked for me (I had to change the path a bit on the command line you gave to us).
I was able to stop and restart Station without issues, restart my laptop and Station without issues, etc.

I just download the last version and it works fine as well, but I couldn’t say if it’s because of the SQL permissions I set before !

I’ll dig up this conversation if I ever have anything new in the future. :grin:

Thank you for your help ! :slight_smile:

Regards

1 Like