Station drains battery life / consumes a lot of energy / triggers the dedicated GPU


(Marc Magnin) #1

The issue I’m facing is that whenever I run station on my macbook pro it requires to use the discrete graphic card of the laptop (not required by other apps) which drains the battery life much faster.
Since Station has the ambition to become a workhorse for many people, it would be great if it could consume less energy on such hardwares.


Here’s the detailed report


Battery Consumption - v1.4 on MBP-13 / MacOS-10
Performance on Macbook Pro 15"
Battery and Lag
Can we make station not activate the discrete graphics cards in Macbook Pro laptops?
Option to Disable Hardware Acceleration
Station leads to switching to Heavy Graphics card on Macbook Pro 2018
(Matt Perreault) #2

Hello, I discovered Station yesterday and want to say firstly I think it’s a huge step in the right direction for an improved work experience.

I work in an environment where I need to work on battery for most of my day and I did notice that today I wasn’t able to make it past noon while using my MacBook. Typically I’d get about 5 - 5.5 hours. I only managed about 3.5 - 4… The only difference was I used Station instead of chrome.

Also, there seems to be some noticeable lag when I type. I’ve only typed in gmail and docs so far.

Thanks and keep up the great work!


(Matthew Lo) #3

The issue I’m facing is …

Significant consumption; avg. energy impact is ~40 after several hours of steady use. Unit is always quite warm to touch and total battery life is cut by a third. To note, the footprint seems to roughly mirror usage of Chrome, which I find quite taxing on my system as well.

Love this app. At this rate, I might switch back to running a series of pinned tabs in Safari. Would be really great if you guys could figure out how to make this a power sipper; truly one app to rule them all.

Thanks so much for listening.


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version:
  • Station version:

(Sai Pathuri) #4

The issue I’m facing is station is draining a lot of battery because it is always using the discrete graphics instead of integrated graphics. Please give me an option to use integrated graphics to get better battery life.


Here’s the detailed report

  • Trigger: Any usage
  • Issue: Station always uses the discrete graphics which results in poor battery life.
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: 10.13.2
  • Station version:1.3.1

(Sai Pathuri) #5

After doing some research, there is a flag --disable-gpu for electron that accomplishes this. On macOS, you can start Station with this flag (not sure if it actually passes through, but so far results are promising) by using the command
open /Applications/Station.app/ --args --disable-gpu

Additionally, this page has some useful information:


(Jonathan) #6

The issue I’m facing is:

Station leads to switching to heavy graphics card on Macbook Pro 2018 15’ from Intel to Radeon. This leads to faster battery drainage.


Here’s the detailed report

  • Trigger: Opening Station
  • Issue: Station leads to switching to heavy graphics card on Macbook Pro 2018 15’ from Intel to Radeon. This leads to faster battery drainage.
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Mac OS X 10.13.6
  • Station version: Stationversion 1.20.0, Electron2.0.2, Chrome61.0.3163.100, Node8.9.3, v86.1.534.41, @getstation/services0.19.4

(Leonardo Manta) #7

Hi Everyone, I reported same issue with GPU discrete card and also battery drain connected to it. Did anyone try with gfxcardstatus for Mac? Will be realease any eventually update that would fix it?


(Chris Cassano) #8

:writing_hand: Brief description of the issue

My problem is that station activates the discrete graphics cards in Macbook Pro laptops, seemingly for no reason. This creates a larger than necessary battery drain. See the photo below for proof.


:warning: Mandatory details

  • :gun: Trigger Just using station normally

  • :boom: Issue station activates the discrete graphics cards in Macbook Pro laptops

  • :movie_camera: Explanatory gifs/pictures 10%20AM

  • :desktop_computer: OS version 10.13.6

  • :gear: Station version 1.3.0


(Chris Cassano) #9

It seems like “open /Applications/Station.app/ --args --disable-gpu” works to disable the discrete gpu.

Why hasn’t Station made that the default when launching?

Doesn’t it bother you guys that people are trying Station then abandoning it because it kills their battery? I recommended station to a number of people who went through this cycle and gave up on it :frowning:


(Daniel) #10

:writing_hand: Brief description of the issue

My problem is that …
Font rendering on Windows 10 with Intel Iris 6100 GPU (running dual boot on MacBook Pro 13’’ early-2015) is poor (type is blurry) when using hardware acceleration. I’ve found this issue multiple times in many different software applications, and the solution is almost always to turn off graphics hardware acceleration.
Is there a way to enable hardware acceleration to become an option in Station’s Options menu?

It looks like electron can perform this: https://electronjs.org/docs/all#appdisablehardwareacceleration, but not without it being built into the app? There also seems to be a discussion here: https://github.com/electron/electron/issues/13368. This thread also identifies the issue: https://communities.intel.com/thread/127903


:warning: Mandatory details

  • :gun: Trigger — Always present

  • :boom: Issue — Blurry Fonts

  • :movie_camera: Explanatory gifs/pictures — See images in Intel Community thread above (https://communities.intel.com/thread/127903)

  • :desktop_computer: OS version — Windows 10 Version 10.0.17134.345

  • :gear: Station version — 1.30.0