Station cannot detect turned-off "Do not disturb" mode on Windows / "Focus assist" is always on


(Przemek Kowalczyk) #1

The issue I’m facing is: Station cannot detect that I turned off “Do not disturb”/“Focus assistant” on Windows 10.


Here’s the detailed report

  • Trigger: Launch Station?

  • Issue: I was trying to turn on notifications in Station, but it’s not possible because it wrongly detects that I have turned on “Do not disturb” mode

    After turning Windows on and off again it detected one notification but bug occured again:
    image

  • Explanatory gifs/pictures (we really need that :pray: ):
    image
    image
    (“Skupienie” means “Focus” in polish)

  • OS version: Windows 10 Pro, version 1803, compilation 17134.165

  • Station version: Stationversion 1.19.0


Do not disturb cannot be desactivated on station... (Windows 10)
Notifications are always in do not disturb
(Lachlan Herron) #2

The issue I’m facing is:
Notifications drawer always states that windows is in “Do not disturb mode” even though Focus assist is off system wide. Also Notifications are enabled and quiet hours are disabled.

Here’s the detailed report

  • Trigger:
    None
  • Issue:
    Notifications drawer always in do not disturb mode
  • Explanatory gifs/pictures (we really need that :pray: ):
    image
  • OS version:
    Windows 10 64
  • Station version: 1.19

(Lachlan Herron) #3

I am also having the same issue.

OS Version: Windows 10 Home, Version 1803, OS Build 17134

Station: 1.20.1


(Jeannuel) #4

I’m also having this issue.
Station: 1.21.0
Windows 10 Home Version 1803


#5

Do%20not%20Disturb

Hi there,

I cannot mange to activate or deactivate “do not disturb” mode on Station.
I read that the “do not disturb” mode of station is linked with the “do not disturb” from windows 10.

I checked all windows 10 settings and my “do not disturb mode” on windows 10 is clearly desactivated…
Why is the “do not disturb” mode then still active on station?

Thanks for your help!


#6

I’m having this problem too. Turned off “do not disturb mode” but still not getting notifications on Station.

Windows 10 Pro with the latest updates
Station 1.24.0


#7

Hello Station Team,

Any updates about this?


#8

Yeah kindly let us know since notifications are on of the most important features on station


(Matt Gallisa) #9

Same issue.
Station 1.25.1
Win10


(Guénolé) #10

Hello,

Same here. Do not disturb mode is not at all activated on my computer and I have the same message


(Jonny Pham) #11

:writing_hand: Brief description of the issue

My problem is that …

Audio notifications are not working. I tried to toggle notifications on and off , tried to change settings, reinstalled, add a exclusion in my antivirus and changed my focus assist settings.

I only get normal notifications without sound and its so frustrating because im trying for so long. It once worked when I reinstalled it but after my restart it did not anymore and tried and tried again it did not work.

It tells me that my focus assist is still on BUT ITS NOT!!!


:warning: Mandatory details

  • :gun: Trigger — SLACK THINKS FOCUS ASSIST IS ON

  • :boom: Issue — SLACK THINKS FOCUS ASSIST IS ON

  • :movie_camera: Explanatory gifs/picturesslack
    windows

  • :desktop_computer: OS version — 17134.345

  • :gear: Station version — 3.3.3


Slack notifications are buggy / duplicated / red dot is constantly here
(João Mário) #12

Any News on this topic? I have the same problem and don’t have any idea how it can be solved.
Thanks


(João Mário) #13

Hello again, I found a solution, at least for me it worked:

  1. The problem
    Station most certainly uses ‘windows-quiet-hours’ module to check if the user is using or not quiet hours. Module Here
    This module is not checking the correct registry key in windows. Thus never knowing if it’s on or off.

  2. Partial Solution
    Go to Registry Editor and put the value that it erroneously checks to 1:
    Computer\HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Notifications\Settings
    Put NOC_GLOBAL_SETTING_TOASTS_ENABLED to 1

Hope it works for you.


(Alex Ivanoff) #14

Same issue here. & @Joao_Mario the registry solution did not work for me


(João Mário) #15

Hi @alexivanoff12, maybe you have other problems, I loaded the Module that I talked in (1), and debugged from there, if you wanna give it a try I can help you.

I don’t think this will be solved in the future, unless they stop using this feature of knowing if the OS is in DND or not. The new “Focus Assist” is a bit diferent in terms of architeture.


(Przemek Kowalczyk) #16

This workaround works :wink:


(Dan Charles) #18

Same problem here on version 1.31.3

The Regedit workaround worked for me, but it’s not an ideal fix.

Windows 10 - Build 10.0.17134