Station becomes unresponsive after long periods of inactivity / freezes when coming from another app / crashes after resuming from standby

I don’t have Drive in my Station Dock and was having this issue…are you sure there’s not something more to it?

1 Like

I also don’t use Google Drive, but Station freezes 100% of the time after a brief period of inactivity.

2 Likes

@Georges I can see why it may take 3 weeks, but I don’t see how it has anything to do with Google Drive? I don’t have it in my Station.

There seems to be a misunderstanding about this thread over there, as this has been going on forever, the thread status has been seemingly random, and now this.

Please let us know if there’s any logs we can send, etc, to clarify the issue. As I mentioned above, I’ve had it freeze as I was using it, so it’s unrelated to inactivity, as the title suggests.

1 Like

Me too!

Get a long hang almost every time mac wakes up from sleep, or I unlock from overnight (does not sleep normally, just goes idle with screen saver).

I’ve looked at Activity Monitor, and one thread is definitely spinning - and the app is taking > 2Gb of data, but, I have NO idea which task is hanging. If I were to guess, I’d say Microsoft Outlook Pro.

I run 2-3 slacks, and outlook mostly. But, I also have telegram, hangouts, and mightytext installed. I do NOT have Google Drive installed!!!

Let me know if I can provide any extra details - If this keeps up, I’ll have to go back to rambox. Station is definitely prettier, but, rambox doesn’t have the hangs.

Oh - one last datapoint. This morning, I went to the OS-X menus, and went to Help / Bugs and Features Request. Station woke back up right after I clicked the menu item, and the link opened on my open Chrome.

Thanks for chiming in. I just tried that function to unfreeze Station and it didn’t work, but you’ve inspired me to look for new workarounds.

Rambox worked great for me, and the sync was nice, but damn is it uninspiring to look at.

@Georges what info is needed?

Exactly the same for me.

I also don’t have drive installed (I have Whatsapp, Messenger, Sendgrid, GA)

:writing_hand: Brief description of the issue

When I press the “start button” on Toggl (https://toggl.com/app/timer),

image

after a while (say, 12-24 hours), Station.app freezes (doesn’t respond to any key or click) and even doesn’t quit on cmd+Q; I have to SIGKILL station to quit.

Here’s a screenshot of htop command while the freezing:
image

(I guess the process consuming many CPU% (202% here) and memory (2193MB here) is more or less relevant to the problem)

I think it’s easy to reproduce for other than me, but if not, I’ll investigate it in depth (please tell me what info is needed; I have an intermediate knowledge of UNIX process and a bit about node.js and TypeScript).


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

macOS Mojave 10.14.5
uname -a: Darwin wsh5.local 18.6.0 Darwin Kernel Version 18.6.0: Thu Apr 25 23:16:27 PDT 2019; root:xnu-4903.261.4~2/RELEASE_X86_64 x86_64

  • :gear: Station version

1.42.1

Hey @wataash, @IanC, @Nathan_Rightnour, @CodeMonkey, @nick1, @afelds, @Tony_Gaspro, @Bhaves_Shah, @Frank_G, @Tom_Avatars, @philoup, @Philip_Osborne, @Thanos_Kazakos, @idjits, @Magnus_Sandstrom, @Snarly, @bhanquier, @Huy_Khoa_Nguyen, @krsB8, @tedi, @Nito_Gomez, @austin.rhodes, @ArthurGodiva, @vlom31, @gtupak, @Tomes, @Geza_Molnar, @Alex_Liew, @xgracea, @Jean-Jacques_Auffret, @goke, @dbenj, @Christoph, @Valdo_Ghafoor :wave:

We think we might have fixed this issue (or maybe part of it) in Station’s latest version (1.42.1) :partying_face:
Could you update your Station and tell us if it’s been solved for you? We’re not perfectly sure as we still didn’t manage to reliably reproduce the freeze.

If the problem is persistent, could you post here a screenshot of your process manager:

  1. In the top bar menu: View > Open Process Manager
  2. Maximise the window to show all the columns (especially the “WebContentsURL” one)
  3. Click on the %CPU column to sort it by descending order.
  4. Take a screenshot of your screen and post it here

To update your Station, just open the preferences (from the “Station” top bar menu) and click the “Check for updates” button on the right.

Hello,
I see a clear improvement on my side. Good job!

1 Like

I use Station daily on both a Mac and PC. Both run their latest respective OS version (10.14.5, Windows 10 with all updates).

So far Station is now working better on my Mac. This screenshot is from my PC, where the app has frozen or crashed twice in the last 10 minutes. On the PC Station is unusable.

1 Like

Get a blue screen after 10 minutes, have to restart Station, using the latest version

1 Like

Same here. Thanks to everyone.

Same issue on a fresh Mojave, any update on this ? this is VERY ANNOYING. more than wavebox

Still occurring in 1.43.2 on Windows 10.

When the freezing occurs nothing about Station works except whichever app you had active last. The menu bar lets you open menus and click things but nothing occurs.

So it’s not possible to open the process manager.

Couple of days ago station stops allowing switching apps after some time (happens 3 or 4 times a day) the currently open app works just fine, i just can’t switch to other apps either by clicking on the sidebar or using the key combos. What’s more irritating is that apps like Whatsapp and Telegram ask for login everytime i restart Station.

Station version  1.43.2
Electron  4.1.4
Chrome 69.0.3497.128
Node 10.11.0
v86.9.427.31-electron.0
@getstation/services 0.28.0

CPU usage may be better …

but when will something be done about the runaway memory usage.

Just checked, it is sitting there in the background … 1.8 GB used???

Reopened station: 1.2 GB of RAM …

With three simple Gmail accounts. Nothing more. Only one account viewed at a time. That seems a very excessive memory load.

I am also having similar issue. After running Station for several days it it consuming lot of RAM - I have five services active and there is 47 (really 47) station processes consuming in total about 7 GB of private bytes. Due to this my PC is using disk (swap) a lot and it’s almost unusable.

Seems there’s at least do distinct issues being reported under this one thread. 1. Apps within Station freeze/don’t load after inactivity and 2. Station itself freezes. I believe the OP was for issue #1, which is what I also am experiencing. I removed 1/3 of my apps hoping to reduce overall load, but it did not help.

Here’s my screenshot of my processes. ToDoist won’t load at all right now.

Same issue here, using AppImage on Linux Mint 18.3
System uptime is 3 days, Station does not switch tabs, crashes on restarting. Also, random logouts from Telegram and WhatsApp.
It gets fixed only on restarting the system. That is not very conducive to long term ease of use.
Here is a crash log.