Station becomes unresponsive after long periods of activity / freezes when coming from another app / crashes after resuming from standby


#1

:writing_hand: Brief description of the issue

I leave my desktops on most of the time (for weeks at a time often). While it is on, I always have station up. Lately, I’ve noticed that when I come to the computer in the morning most days, I can no longer switch between apps as everything except the currently loaded webpage becomes unresponsive. I can’t click any of the app icons in the station bar on the left, nor can I use the file menu at the top. This has forced me to restart station at least once pretty much every morning for the past few weeks.


:warning: Mandatory details

  • :gun: Trigger — Leave computer w/ station running on over night

  • :boom: Issue — Station becomes unresponsive and must be restarted

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Windows 10 v10.0.17134

  • :gear: Station version — 1.24.0


Station freezing
Station unresponsive, unable to be closed/killed after device hibernate/resume
Station is stuck when recovering from standby mode
Station freeze when leaving the app in background
App occasionally freezes and the process is impossible to end unless Windows is restarted
Frequent crashes on Station 1.31.2
Locks up after time passes
App freezes regularly
Station occasionally freezes when coming from another app
Station is always freezing making it unusable
Station not responding to keyboard/mouse events for about a minute after not being used for a while
Station freeze after resuming from standby
(Tom Avatars) #2

:writing_hand:Brief description of the issue

When working with other software windows and going back to Station, it’s freezed and it needs a lot of time to be usable again. I often have to close and relaunch because waiting is too long.
Station should be a help with time, henceforth, it actually does the opposite, please fix this!


:warning:Mandatory details

  • :gun: Trigger — Leaving Station in background and going back to it

  • :boom: Issue — Freezed. Needs way too much time to be usable again.

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Mac OS 10.13.6

  • :gear:Station version — 1.24.0


(Christoph) #3

:writing_hand:Brief description of the issue

Station lags sometimes when you come from another app. The App is frozen, after 2 minutes it’s back again. This happens since the last update


:warning:Mandatory details

  • :gun: Trigger — changing from another app to station

  • :boom: Issue — lags for 1or 2 minutes

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — win 10

  • :gear:Station version — 1.24.0


#4

Yes!!! I do have the same issue too…

  • :desktop_computer: OS version — win 10
  • :gear:Station version — 1.24.0

(Andreas Wagner) #5

Me too… :thinking:
Sometimes it is frozen until a new start…


(Christoph) #6

bug still present in version 1.25.1


(Christoph) #7

push push
…got the same Bug now on a different Computer, also windows.


(Michael Clinton) #8

I experience this as well on 1.25.1 (on macOS Mojave). Sometimes I have to kill Station, other times it comes back in a few seconds.

Been trying to record it, but it’s not consistent.


(Bojan Peček) #9

The issue I’m facing is …
The app just freezes for me today, happened already 3 times. Seems to be connected to the popup

https://www.dropbox.com/s/wris2xva7h9b70t/Screenshot_829.png?dl=0


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version:
  • Station version:

(Bojan Peček) #10

When the pop up is open and I click any of the app on the sidebar Station freezes.


(David Baxter) #11

Not sure why, but the Windows Station app (just updated to 1.7.1) is freezing for a bout 5 seconds on a regular basis…

Didn’t used to do that, but it is getting tough to use the app.

Anyone else having this? Any work around?

David


(Sam Borick) #12

:writing_hand:Brief description of the issue

My problem is that I open station, go do my work elsewhere, and when I come back to station it does not respond to any clicks. I have to force quit and restart. Repeat,


:warning:Mandatory details

  • :gun: Trigger — some amount of time passing

  • :movie_camera: Explanatory gifs/pictures — None needed, the resulting behavior is not explainable by a video or gif because station does not DO anything. The error is that station does nothing, ever.

  • :desktop_computer: OS version — macOS High Siera

  • :gear:Station version — 1.24.0


(Jeremy Bauer) #13

I’m having the same issue. It started after the last update.


(Tom Avatars) #14

Same here! It seems to freeze and I have to wait a while before I can use it again.
I’m on OSX 10.13.6


(Manuel Merz) #15

Yes noticed the same on my machine (Win 10 Pro, 64-bit). Hope it get fixed soon.


(Jean Jacques Auffret) #16

:writing_hand:Brief description of the issue

My problem is that after returning to Station after a period of doing something else on my computer, Station gets unresponsive for typically one minute before it comes to life again.


:warning:Mandatory details
Interacting with applications does not work, and switching apps does not work either.

This make Station close to unusable, and I’m on the verge of dropping it and getting back to my old browser (a pity since I love Station and your great work on it…)

  • :gun: Trigger
    Not using Station for a while.

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version
    Mac OS High Sierra (10.13.6)

  • :gear:Station version
    1.25.1


#17

:writing_hand: Brief description of the issue

The app freezes at least once a day and is impossible to end the process unless Windows is restarted.


:warning: Mandatory details

  • :gun: Trigger — Unknown. Seems to occur when the app is not focused.

  • :boom: Issue — The app freezes at least once a day and is impossible to end process unless Windows is restarted.

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Windows 10

  • :gear: Station version — 1.25.1


(Ashwani Agarwal) #18

Having the same issue. Nothing in debugger or anywhere.

Though the application which is open inside Station works a bit (I’m able to scroll; but not click anywhere)

But the Station is unresponsive.


(Tom Avatars) #19

:writing_hand: Brief description of the issue

I use Station a lot, but when I’m doing something else, after a while, when I go back to station (with Cmd+tab) it’s freezed. I have to wait a loooong time before I can use it again, or close/open the app. In one word : Unusable.


:warning: Mandatory details

  • :gun: Trigger — App in background, then go back with cmd+tab

  • :boom: Issue — Freezed, performances issues

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — OSX 10.13.6

  • :gear: Station version — 1.26.0


(Marc Frey) #20

same experience here. it’s always the matter when returning to Station after a while, especially after longer periodes when the computer returns from silent mode