Station 1.49 is out

Released on September 13th

:recycle: What we changed
Revamped stuff

  • Upgrade to Electron 6 (Chrome 76)

:beetle: What we fixed
Squashed bugs

  • Fixed Clearbit extension
  • Several fixes for Quick-Switch-

hi,
downloading it will take hours from here, Istanbul, Turkey. Why is that?

Hi @eylem_akcay ,

Have you tried using different wifi hotspots? It takes 2 min to download from Paris.

It was only on github downloads (i tried two other packages, etc.) and a vpn i tried could not solve the issue. However, now the problem is disappeared without cause, and i can easily upgrade station.
Thank you for your interest.

Hello - thank you so much for this platform - it’s been tremendous so far.

For some reason, I’m not able to update to the latest version 1.49. My current version is 1.48.1 and when I go into the preferences it states that I have the latest version. Is there something I might be doing wrong? I’ve rebooted and relaunched to no avail.

I’m wondering if I need to now uninstall and download the latest version as a new install?

How about mixmax?.. This has been broken for quite a while - can’t use any of our gmails without it.

Hello, hello !
I have version 1.48.1 and Station’s update button also tells me there is no version 1.49.0. sadly…

I wanted to download the latest .AppImage for my Ubuntu 18.04LTS, but Station’s website is appearently not uptodate : :slight_smile:


MacOS : 1.49.0
Windows : 1.49.0
Linux : 1.48.1
mmm… :thinking: … seems not normal :grin:

Thanks a lot for your work !