Spellcheck configuration / disable spellchecking / change language

As a non-English user I want to setup spellcheck so that Station respects my language preferences.

Currently Station automatically spellchecks my writing in English, which is my default OS language. Since I primarily write in other language, I have added extra spellcheck dictionary to my OS, but Station doesn’t respect that. Unlike in web browser, there are no configuration options to choose language for spellchecking, addition of extra languages or disabling of spelling highlights.

I’d like Station to allow me customize spellchecking similarly to Chrome or Firefox, e.g. by right-clicking on textbox. More specifically:

  • Allow me to choose preferred language for spellchecking (preferably using dictionaries installed in my OS),
  • allow me to disable spellchecking completely.

This would make Station accessible for non-English and multilingual speakers.

Yes please! I now have a bunch of red lines in my emails, while it’s perfect Dutch! Makes it very hard to actually make sure that there aren’t any errors in there.

If it’s hard to add other dictionaries, please make it possible to disable spellcheck.

1 Like

There’s no option to disable spellcheck within the app.

This is the right click menu in station:
10

The red dotted line is really annoying… Or maybe I’m just too stupid to find the option?


Here’s the detailed report

  • Trigger: Misspelled words
  • OS version: MacOS 10.13.3
  • Station version: 1.3.1
1 Like

I write in a non-english language and in chrome the spellshecker supports this.
Station doesn’t have the option to change the spellcheck language (right-click menu option elsewhere)

Am I misssing something?


Here’s the detailed report

  • Trigger: writing in any text box (i.e Google Inbox)
  • Issue: (no croatian language spellcheker, like in chrome)
  • OS version: win 10
  • Station version 1.2.0

Just like with browsers, we need the ability to disable spellchecking.

1 Like

Allow disabling the spell checker

When I write in various apps, I keep seeing red dotted lines under words in my text. Please provide an option to disable spell checking, just like in Chrome.

SUMMARY I’d like Gmail in Station to support multi-language use just as Gmail can in Chrome.

As a person who regularly switches between to languages, I want the spell check in Gmail to recognize that I’m often using a language other than English so that I only see words underlined in red when I actually made a spelling error (and not every time I a language different than English).

GIVE US CONTEXT (tell us about the current experience)

When I use Gmail in Station and start typing in German, basically every word is underlined because Gmail thinks I made spelling mistakes.

PROVIDE DETAILS (tell us what you are looking to change)

I’d like Gmail in station to use more than one dictionary at once.

DESCRIBE THE IMPACT (how would it change your experience)

The main advantages for me are: I’d start using Gmail in Station. Right now it’s too annoying as the spelling suggestions don’t make any sense when I’m writing in German.

The issue I’m facing is: all the words I type in other languages than English get a red line under them.

Since we’re a Swedish company - essentially everything I write within the Station app gets marked as being spelt wrongly.


Here’s the detailed report

  • Trigger: All the time

  • Issue: Red line under words (spell check)

  • Explanatory gifs/pictures (we really need that :pray: ): 47

  • OS version:

  • Station version:

1 Like

This feature would be great. Or have like Google Chrome where you can have multiple languages activated at the same time and the browser detects and corrects all of them (at the same time).
This will be very helpful for multilanguage users that write emails/messages/notes in different languages.

Many thanks!

2 Likes

Yes, the feature described by AlvaGB (spellcheck every language enabled in your preferences: usually your native language + english) is particularly useful!

1 Like

Installed on Win7 64…appears English is not being used for spell check. Is there a setting for this?

Need to change my language to Australian (or UK) English! The spell checker telling me that ‘socialise’ and similar is incorrect is frustrating.

Thanks.

To take this a step farther than just for multiple language support it needs to have a dictionary that is editable. For example if I regularly email someone name Rajiv it always says that the spelling is wrong. If I use the name of an application like Altium it says the name is spelled wrong. If I use an English word that is not in the untouchable dictionary it says it is spelled wrong.

That is fine if the dictionary allows the addition of words. Gmail the application I am using allows me to add words to the dictionary. But when I use Gmail in Station the words I have added to my gmail dictionary are still highlighted as misspelled.

Here is an example of what I get in Station with a misspelled word.
image

Here is the same word with the spelling menu from gmail.
image

Please make the dictionary functional or allow it to be turned off, or just use the dictionary included in the application that you are running.
Thanks

A post was merged into an existing topic: Spellcheck doesn’t work / works intermittently / red dotted lines everywhere / every word is marked as wrong

This is a must have. We are not all using english all the time.
Is there a workaround yet?

Any news here? It’s really starting to annoy me

:writing_hand: While I type an email, the misspelled words do not get underlined in red

There are a few other threads mentioning similar issues, but nothing exactly like this. I just don’t get the red underlines when I type emails in Gmail. I uninstalled and reinstalled Station. The only way to get spellcheck is to manually open the Gmail spell checker. I would prefer continuous spell check as I type. I believe the red underlines worked before, but has not worked in the last few weeks.


:warning: Mandatory details

  • :gun: Trigger — Typing in a gmail email

  • :boom: Issue — No red underlines for misspelled words

  • :movie_camera: Explanatory gifs/picturesimage

  • :desktop_computer: OS version — Windows 10 Pro

  • :gear: Station version — Stationversion 1.42.1
    Electron4.1.4
    Chrome69.0.3497.128
    Node10.11.0
    v86.9.427.31-electron.0
    @getstation/services0.28.0

@Georges Thanks for merging the topics. I believed my issue to be slightly different from this one, but maybe not? Can you give an update? It’s hard to use Gmail for work without spell check! Thank you!

On OS X, is there a way to enable the built-in spellchecking usually available in an app’s Edit menu? I can’t live without “Check spelling while typing”.

Same problem facing with Windows 10 home
Spell check is not working in all apps including gmail

Stationversion 1.44.1
Electron5.0.7
Chrome73.0.3683.121
Node12.0.0
v87.3.492.27-electron.0
@getstation/services0.29.5

But it is working in my Macbook pro 15