Slack workspace icons not showing up in the dock

✅released
📦station-v1-14-x

(Peter Schott) #1

I just added a new Slack channel for “rdtn.slack.com” and the icon for their channel isn’t showing at all. It’s not like the rest where it’s just a really tiny icon of the channel. There’s no icon at all except the default (large) “Slack” icon. Restarting/updating hasn’t seemed to make a difference. I see the icon when I use the Slack website.

Running on Windows 10 Enterprise 64-bit (Creator’s Update).
Station 1.3.0


Slack Workspace Icons not showing up on Dock Icon
(Peter Schott) #2

Any updates on this? Any ideas on what I might try to get the icon to show up? This is still missing in v1.9.0.


(Groot) #3

I am also having the same problem - I actually have Station installed on two different machines, the icons show up on one and not the other. Anyone know how to fix? Thanks.


(Groot) #4

To be clear - this is NOT the same issue as this one (Swap slack logo with slack workspace logo). This is definitely some sort of odd bug. Here is how it looks in my Station right now:

24%20PM

After some wrestling with it, it is also incredibly sticky. I tried the following and none of them fixed the issue:

  • Removing the Station data folder (from Application Support on a Mac)
  • Removing the Station app and reinstalling
  • Doing both of the above
  • Trying to mess with the caches under the development tools

None of those have worked, so there must be some other issue that is causing it.

It is worth noting that I have a second user on the same machine (a MacBook Pro) running Station with the same Slack teams, and the mini-icons display just fine. So it’s something particular to a given Station instance. I’m not sure what other data Station could be caching that could cause it though, given the above troubleshooting.

Anecdotal possibility (possibly a red herring) : I know that I accidentally mis-logged into one of my slack groups, and I think the bug manifested after that. The mini-icon showed up for the first Slack group I added that, but never has since then - including for the original slack group, after I removed it and re-added it during the troubleshooting.

That’s the info I have. Hopefully helpful in debugging.


(Nadia Razak) #5

I would like to have two Slack workspaces on my dock, but I can’t differentiate between the two. One of my colleagues has the workspace icons at the bottom of the Slack icons. Why is it not appearing on mine?

Thanks

46 AM


(Alessandro Pelly Benassi) #6

‘glad’ to see the team has been completely ignoring this for 6 months now… I work on 9 different teams and it’s a nightmare to go through all the Slack instances every time.

I’m done for good with Station!


(Groot) #7

Yeah, unfortunately this is keeping me from using Station as well. I tried to give as much info as I could on it, hope it will be fixed at some point. I did enjoy Station when I was using it before this issue.

It is quite odd to me that cleaning out every obvious Station file still doesn’t get rid of the problem, especially since it doesn’t occur across multiple machines.

Hope it is fixed someday.


(Alessandro Pelly Benassi) #8

I don’t wanna sound like a shill but I’ve been giving Franz a try and it works great with Slack and icons. The downside is that it doesn’t support as many apps as Station, but it covers all I need.


(Georges Abi-Heila) #9

We just released a new version of Station (v1.14.1) that should solve this issue.
Please update and tell us how it goes :wink:

Thanks for your patience.