Slack messages are not getting marked as read / red notification dot is always here

Thanks for the report @krishna_fathom

Same here ! Even when hitting Esc button !

Facing the same issue. Would be so useful if this gets fixed!

Facing the same issue. The notifications do not disappear when after I have replied to the notification. Escape button doesn’t work either.

Stationversion 1.8.2
Electron1.7.8
Chrome58.0.3029.110
Node7.9.0
v85.8.283.38

I’m not sure if this is similar or not, but I have two slack accounts where the new notification icon will not go away. They both do not sync the logos as well. I’ve tried removing/re-adding the accounts with no luck.

image

Stationversion 1.9.0
Electron1.7.13
Chrome58.0.3029.110
Node7.9.0
v85.8.283.38
@getstation/services0.12.0

I’m having the same issue with Slack.

Add me to the list of users experiencing this same issue.

Same here
mac osx
Stationversion 1.13.1
Electron2.0.0
Chrome61.0.3163.100
Node8.9.3
v86.1.534.41
@getstation/services0.16.3

Soooo annoying! Please fix asap.

+1 to this getting fixed. I’m a zero-unread-messages fanatic, so this is extremely frustrating. Using the latest version of MacOS and Station at time of writing.

Same. I am having the same issue. It happens occasionally and is very annoying. I have to revert to using the actual slack app

:writing_hand: Brief description of the issue

I’m seeing the little red notification dot on all slack channels even when nothing is updated. Is there a way to change this behaviour? For example on messenger, it’s just a faded logo, and when a new message comes in the red dot will appear (which I guess is how it should function).


:warning: Mandatory details

  • :gun: Trigger — General use of station with multiple slack accounts in the sidebar

  • :boom: Issue — notification dot always on (should be off until a new message is there)

  • :movie_camera: Explanatory gifs/pictures47

  • :desktop_computer: OS version — Mojave 10.14

  • :gear: Station version — 1.29.0

This issue is still ongoing. Is it going to be fixed?

Facing the same issue. PLease get this fixes, so frustrating!!!

I also face this issue but when I can’t exactly narrow down when and why it happens because it doesn’t always occur. When I restart station then slack goes back to behaving correctly. FWIW whenever the unread count doesn’t change the slack keyboard shortcuts also stop working.

Can we get any updates on this please? This issue has been going on for a looong time now, any word from the devs would be great! Thanks!!

I just started experiencing this issue today. It’s isolated to new messages in my Threads. Are there troubleshooting steps or workarounds I can try?

Started experiencing this issue in Threads only. When going to Threads, one message is marked as “unread”, but even after clicking on the message in the thread or reading the last message in the thread, it does not appear as read and Threads remains bolded with a notification dot on my app icon.

I tried quitting the app and restarting it, but that did not resolve the issue.

The thread also appears as unread when I open it on my mobile iOS Slack app.

Slack Version: Version 3.4.2 (Direct Download)
OS Version: macOS Mojave version 10.14.5

The use of Shift Esc t o clear unread got me working again

I’m experiencing this with Threads now. Always shows as unread, which results in a green notification dot on the app icon. I currently have nothing in threads, and have attempted shift+esc to clear all unreads, with no luck.

Slack: Production 4.0.1 64-bit
OS: Win 10 Ent 10.0.17134

Have the same problem :frowning: Did anybody resolve it?