Salesforce is buggy / lookup modals don't work in Lightning / multiple error popups / can't upload file

⚙️in-roadmap
#1

Every-time you put your mouse on a user, you get an exception.

I’m using Salesforce in Lightning mode. This behavior do not append in chrome or safari.


Here’s the detailed report

Popup Windows do not interface with SFDC main page
Salesforce app errors when clicking on notifications
Salesforce is buggy in Station
Constant Error Popups in Salesforce Lightning
Lookup modals and Notifications In Salesforce Lightning
Hovering over any interactive link/popup in Salesforce triggers error
Cannot Upload Files to Attach to Email in Salesforce
Salesforce isn't working
Salesforce, Opportunity reference - buggy
Popups don't work in Salesforce
Salesforce
(Mitch Woloschek) #2

The issue I’m facing is lookup modals when you are searching for a specific record on a form. I’ve attached an image of the magnifying glass icon I’m referring to. When you click on it, it doesn’t open up the lookup modal. Also, the notification button at the top right corner in Salesforce lightning errors out. “Uncaught Assertion Failed!: Target is undefined or missing : undefined”

30 PM

  • OS version: macOS Sierra 10.12.6
2 Likes
(Nic Poulos) #3
  • Issue: Salesforce error triggering a popup dialog box (see screenshot below). You can hit OK and it usually pops right back up, but after 4-5 times hitting OK it’ll go away, at least for a few mins.

  • Trigger: Opening latest version of Salesforce (Lightning) in Station; also triggers again randomly while using SFDC (every few minutes or so)

  • Screenshot: https://cl.ly/pNsz

  • OS version: MacOS High Sierra 10.13.2

  • Station version: 1.4.1

3 Likes
(Josh Lucas) #4

The issue I’m facing is …
When trying to use salesforce in Station, certain buttons don’t work. Pop open windows seem to not always open. Basic functionality of Salesforce keeps breaking.

Here’s the detailed report

  • Trigger: Trying to click certain buttons or links in SFDC
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ): https://cl.ly/1z3T0G171F0a
  • OS version: 10.13.3
  • Station version:

Stationversion 1.4.1
Electron1.7.8

Chrome58.0.3029.110

Node7.9.0

v85.8.283.38

@getstation/services0.8.0

2 Likes
(Nic Poulos) #5

Hi guys. Any plans to fix this? It makes Salesforce unusable in Station. Thanks!

1 Like
(Rob Kenedi) #6

Hi gang, I’m putting in my vote for a fix - love Station and this would be one of (if not my top) used apps! Please do let us know where your thinking is on this. Thanks!

2 Likes
(Jason Hibbert) #7

Essentially, Station receives an error when I click on the notifications icon in the Salesforce app. I’m guessing it’s something to do with how the notifications feature works and Station doesn’t like it? For now it seems the app is unusable if you wish to view your notifications.

1 Like
#8

The issue I’m facing is … Salesforce consistently runs into issues. I have not figured out any exact sequence of events that causes this error. Here is the error text: “This page has an error. You might just need to refresh it. First, would you give us some details? (We’re reporting this as error ID: -701908082)”


Here’s the detailed report

  • Trigger: Unknown
  • Issue: Error ID: -701908082
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: mcOS High Sierra
  • Station version: 1.10.0
(Augustin) #9

using SF, when logging an activity related to an opportunity, it’s not possible to select the opp in the pop up. need to Copy & Paste.

  • OS version: Windows 7 pro
  • Station version: 1.11.2
(Aj Silverberg) #10

Pop up windows needed for Salesforce Functionality

As a user I want the ability to have pop up windows so that I can access Salesforce.com’s full functionality.

GIVE US CONTEXT (tell us about the current experience)

When I am doing admin work in Salesforce it requires searching through account records and linking cases/leads to accounts. In order to find the right one salesforce presents a pop up dialog box.

PROVIDE DETAILS (tell us what you are looking to change)

I’d like pop-ups to be supported.

DESCRIBE THE IMPACT (how would it change your experience)

The main advantages for me are: that I can continue to to use salesforce which represents about 30% of my time but simply can’t without the popups. I would use station as a homebase for many of my web apps if it had the functionality and possibly bring my team on board as well.

(Rob Kenedi) #11

Hi everyone, I’m still experiencing what the OP wrote. I get error modals constantly in Lightning such that I really can’t use Salesforce. Any thoughts as to when / if this may be addressed? Thanks very much - otherwise, love the product immensely.

1 Like
(Clément Desplats) #12

:writing_hand: Brief description of the issue

My problem is that when I click anywhere I’ll get an error pop-up that asks me to explain what happened. And I can’t even fill it.


:warning: Mandatory details

(Daniel Eversole) #13

The issue I’m facing is:

When searching for a particular user in the forecast tool, I am unable to select the user from the popup window. Functions within each window work without issue. For example, I can call the popup window to search user names and within the search popup window call the list of users, but when I want to select user to view back on the main window, nothing happens (In image below, I am wanting to select the second user on the list, but I cannot view their forecast after selecting on the popup window). Tried on Mac and PC.


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
    image
  • OS version: 10.13.4 (17E202)
  • Station version:1.13.1
(Ed Vyse) #14

I have just started trying Station out to use with SalesForce Lighting and Google Apps. SaleForce Lighting is my main tool but throws up an error on a fair few links clicked. I uses ‘Cases’ and a few case templates, if I change the templete I get the following error:

46

51

This page has an error. You might just need to refresh it. First, would you give us some details? (We’re reporting this as error ID: -1452096547)

The same error happens if I click on my profile and Notification at the top right.

Any advise to fix this error.

I am using a MacBook Pro (13-inch, Mid 2012) with macOS Mojave 10.14.2.

3 Likes
#15

:writing_hand: Brief description of the issue

Hovering over the Opportunities link the quick actions bar, and when hovering over an account owner’s name, such as on an Opportunity object, trigger a popup message that sends an error report to Station. The screen is grayed out and the only option a user has is to close the screen and return to the previous page. Thus, there is no way to actually perform the aforementioned actions.


:warning: Mandatory details

  • :gun: Trigger Clicking or hovering over links that trigger a popup or interactive feature

  • :boom: Issue Error message shows up on screen, action cannot be completed

  • :movie_camera: Explanatory gifs/pictures — ![55%20PM|690x406]![07%20PM|690x421]

  • :desktop_computer: OS version Mac OS High Sierra

  • :gear: Station version 1.39.1

2 Likes
(Matthew Wilson) #16

:writing_hand: Brief description of the issue

My problem is that when I try to attach an attachment via “Upload Files”, the file choosing window does not pop up.


:warning: Mandatory details

  • :gun: Trigger — Choosing “Upload Files” from email > paperclip icon

  • :boom: Issue — Uploading files cannot happen due to popup window being blocked

  • :movie_camera: Explanatory gifs/picturesimage

  • :desktop_computer: OS version — MacOS 10.14

  • :gear: Station version — 1.39.2

1 Like
(Matthew Wilson) #17

I have not seen any update on this, any chance I can find out if this is being looked into? Other applications appear to be impacted - it seems there’s a popup blocker.

3 Likes
#18

I would also love an update or a workaround