Prevent Station from making requests to openDNS

The issue I’m facing is …

Apparently Station makes requests to opendns for some reason, which is blocked on my company network (which means over 1000 alerts to our security team every hour from my laptop).

Is there a way of disabling this? i.e. can it be configured to use my laptop’s DNS settings directly instead?

Or would you need to add this feature in a new version of the app?


Here’s the detailed report

  • Trigger:

  • Issue:

  • Explanatory gifs/pictures:

  • OS version: macOS 10.11.6

  • Station version:
    Stationversion 1.0.8
    Electron1.7.8
    Chrome58.0.3029.110
    Node7.9.0
    v85.8.283.38

Hey @strawberryutopia,

Thanks for reaching out!
You may have noticed that the color gradient of your Station changes during the day: it’s actually synced with the course of the sun in your timezone. To do that, we use a library that pings a geoIP service via openDNS, thus your multiple security alerts…

We unfortunately don’t plan on changing that in the near future, but at least you know we’re not doing something shady :wink:

Thanks.

Well, when you do allow the option to disable that, I’d love to come back to Station :slight_smile:

Alas, with that feature in place, it is prohibited on the corporate network.

1 Like

You could block the openDNS adress in the windows HOST file :wink:
This way the traffic never reaches the network itself

1 Like