Prevent Station from launching on startup / disable autostart / hide Station's window on computer login / sync Station's settings with System Preferences

✔️workaround

(JKVeganAbroad) #1

The issue I’m facing is that when I manually remove Station from the macOS “Login Items” (in the System Preferences Pane), Station automatically adds itself back upon launching.

Station should recognise that it’s been removed manually from macOS’s native System Preferences pane, and respect that decision, rather than restoring Station every time you launch Station.


Here’s the detailed report


Can't mark Station to start hidden when added as Login Item
It keeps opening on login
(JKVeganAbroad) #2

I have just noticed that a workaround for this behaviour is to disable “Auto launch” from the [Station » About Station] menu in the macOS universal toolbar. This is a little unintuitive because to change options there’s usually an [Edit » Preferences] or [Tools » Options] menu in most apps.

Here’s a screenshot of where to find it.

Please don’t delete this post/thread, because it contains the necessary keywords for other people to find this thread and avoid creating duplicate bug reports.


(Stefano Monteiro) #3

It keeps opening on login. I turn it off but it opens on login every fucking time!!! Either fix it or I delete it!!!


(Jonathan Coetzee) #4

:writing_hand: Brief description of the issue

My problem is that I can’t hide Station when adding it as a Login Item.


:warning: Mandatory details

  • :gun: Trigger

    • Add Station as Login Item
    • Try to mark it as hidden
  • :boom: Issue

    • The checkbox immediately deselects itself
    • Station grabs my screen on login instead of starting hidden which is what I want.
  • :movie_camera: Explanatory gifs/pictures

41

  • :desktop_computer: OS version: 10.14.1

  • :gear: Station version: 1.27.1