Notification are not working: no red dots / activity badges on the apps' icons


(Andrei) #1

Hi,
I get notification messages but there are no dots or badges visible, either on the taskbar icon or on the app icons in the left sidebar.


Here’s the detailed report

  • Trigger: Receive notifications (for Gmail)
  • Issue: I can see in other people’s screenshots that they get a little dot over the app icons when they get a notification:

firefox_2018-05-16_14-29-31

Those dots don’t appear in my Station.
Also, I’m not sure if there should be a notification on the taskbar icon. There isn’t on mine, so if there was supposed to be one it isn’t working.

  • OS version: Windows 10 ver. 1709
  • Station version: 1.11.2

Red dot notification not working
Badge Icon
(Alan Reyes) #2

Im having the exact same issue, have you found any solution?


(Bryan Grandy) #3

I am as well. Is an admin going to help us with this fairly important issue?


(Georges Abi-Heila) #4

Hey @andreyu, @Bryan_Grandy & @Alanrey00,

I’m having a hard time reproducing this bug and gonna need your help :ambulance:

  1. Are you sure you enabled notifications in Station / disabled the focus mode?
  2. Are you sure you enabled Gmail notifications in Station / didn’t silence the individual app?
  3. Are you sure you disabled your OS’ “Do Not Disturb” mode?
  4. Have you tested the behavior in your default browser: do you receive notifications there?
  5. What version of Station are you using and on which OS are you?

(Alan Reyes) #5

I endend up reinstalling windows and it worked as normal


(Ignacio Letelier) #6

Same Issue here, no red dots. Notifications popus and notifications center working OK, but no red dots.

Sation 1.122.0
Electron 2.0.2
Chrome 61.0.3163.100
Node 8.9.3
V8 6.1.534.41
@getstation/services 0.21.3
macOs Mojave 10.14

Amazing app!! thanks guys for all the love/work !


(Albin) #7

Same issue as well. Seems working for Facebook Messenger, but not for GMail nor WhatsApp nor LinkedIn.

Stationversion 1.23.0
Electron2.0.2
Chrome 61.0.3163.100
Node 8.9.3
v86.1.534.41
@getstation/services0.21.3
OS : macOS 10.13.6

Let me know if I can provide you more precise details :slight_smile:


(Thomas Brennan) #8

I have the same issue. Unfortunately it’s making Station very hard to use. I do not currently get any notifications within the App or an app badge icon in the doc. --I’m using the latest Mac OS.


(Alex Monteiro) #9

Same issue here. Don’t see any red dots when notifications come in. Have checked all notification settings and enabled everything I can find.


(Ivan Ivanoff) #10

Same Issue here
Stationversion 1.24.0
Electron2.0.2
Chrome61.0.3163.100
Node8.9.3
v86.1.534.41
@getstation/services0.21.4
macOs Mojave 10.14 (18A391)


(Eric Evans) #11

I’ve had this issue as well and I believe it’s an issue with gmail’s newest update and not with station. To fix it try the following:

  1. Click on the cog icon in the top right, choose settings.
  2. In the general tab scroll down a bit, be looking for a “Desktop Notifications” section. On mine when I updated it turned this off by default, selecting “New mail notifications on” fixed this issue.
  3. Try sending yourself an email from another account.

Hopefully that works for you!


(Albin) #12

Same issue here.
@Zipbug it could be a solution for GMail, but I have it for Whatsapp… but GMail is working correctly. Really strange behaviour.

If I can provide any help/details/anything, please let me know.


(Ali Shafai) #13

:writing_hand: Brief description of the issue

My problem is that …
On my Mac dock I only see a badge notification when there is a GMail unread email, but I don’t get a badge notification on the dock for WhatsApp, Outlook Pro, LinkedIn, Slack, etc…

Is there a way to enable that?


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

  • :gear: Station version


(Evan Smith) #14

:writing_hand: Brief description of the issue

My problem is that …the red dot by the app that has the new message does not appear. I get a red dot on the bottom as a new notification, but no red dot on the actual app up top on the left bar.


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

  • :gear: Station version