Launching Station triggers camera on OSX / webcam goes on on Station start / typing in Station triggers Facetime

The issue I’m facing is:

On my OSX 10.13.6 High Sierra, launching Station triggers the mac’s camera on. No pop-ups, no nothing. It just goes green. What’s up with that? I don’t feel comfortable with this. Once I kill Station, the camera goes off.


Here’s the detailed report

  • Trigger: Launching Station
  • Issue: Camera turning on without any concent
  • Explanatory gifs/pictures (we really need that :pray: ): not needed
  • OS version: OSX 10.13.6
  • Station version: 1.21.0

Same for me. I’m totally not comfortable with this.

Hey @steve_newcomb & @fen,

That’s indeed really weird.
My feeling is that you’ve got an open page or app (within Station) that uses the camera. Can you hover over each of your dock icon and check every opened page? (more info here)

Hey @Georges, thanks for a reply. This bug is weird. Literally nothing was using my camera. To make it even more strange, after a few hours it just went away. I think it might be connected with OSX-native weirdness. Shall the bug return, I’ll let you know.

When I open my station, the webcam of my laptop instantly goes on. I have tried to relaunch station, restart computer etc with no result.

Station runs the camera when you open the app, why is that?

I have found the issue for me is that I added the Google Meet extension to my Station. No matter what I do, merely adding Meet enables my WebCam. I removed the Meet extension and I can now run Station without my webcam coming on.

I’ve checked and I have NO conferences open in Meet. It seems to be a bug in Station.

Without this work-around, I would NOT use Station.
Would like to have it fixed so I can experience the integration of all google apps in one application and get it OUT of my browser.

Same for me, I also have Google Chat in my station. I have switched over to Franz to handle my communications until this bug is fixed. I’m not comfortable with my webcam staring at me while I work and Chat is one of my integral apps, where I can live with using Drive and other non-communication apps in browser.

Hey @gregg_gianopulos, @emcampbell, @agmatias, @kankaanerno, @fen

Thanks a lot for contributing🙏
I’m having a hard time reproducing this bug: even when I have Meet & Chat installed in Station, my webcam stays off.

  1. Are you sure that it is those apps that trigger the webcam in Station?
  2. Have you tried removing them and adding them again?
  3. Can you record your screen with your phone and show us how the webcam is off and the goes on after installation?

I understand it’s a bit of a hassle but without reproduction steps, we won’t be able to solve the issue.

Have an awesome day!

I can confirm it happens without chat too, I did most recently add chat to my workflow and made the connection between the two when I saw this forum. Upon further inspection it doesn’t seem to be related to any of my apps, after recording this video I proceeded to uninstall Facebook Messenger, Discord, and Slite and it still occurred exactly how it shows in the video

https://drive.google.com/open?id=1axlKGzG9HUjuuJsCIHkJRlv7HQ8ZhEyp

Other apps installed are Google Inbox (3 accounts), Slack (2 workspaces), Google Drive, and Todoist. My guess at this point is that it’s still related to google somehow, as I can receive google chats while in any of their services.

1 Like

Same issue on Windows. As others have mentioned, as soon as I exit station, camera turns off. When I launch, camera will turn on after a few minutes. I’ve attempted removing Meet, Hangouts and Zoom, but the issue remains.

Having the same issue as well on Mac. Clear as day, laptop cam light is on when Station is open, turns off when I quit Station. Creepy and don’t like using it until it gets fixed.

This is what is going on, from my log from Oversight:

2019-02-03 16:29:48 +0000: Video Device became active (FaceTime HD Camera (Built-in), process: Electron Helper, /Applications/Station.app/Contents/Frameworks/Station Helper.app/Contents/MacOS/Station Helper)
2019-02-03 16:29:51 +0000: Audio Device became active (Built-in Microphone, process: Electron Helper, /Applications/Station.app/Contents/Frameworks/Station Helper.app/Contents/MacOS/Station Helper)
2019-02-03 16:30:09 +0000: user clicked ‘allow’ for {
alertType = 1;
device = 2;
processID = 2393;
processName = “Electron Helper”;
processPath = “/Applications/Station.app/Contents/Frameworks/Station Helper.app/Contents/MacOS/Station Helper”;
}
2019-02-03 16:30:10 +0000: user clicked ‘block’ for {
alertType = 1;
device = 1;
processID = 2393;
processName = “Electron Helper”;
processPath = “/Applications/Station.app/Contents/Frameworks/Station Helper.app/Contents/MacOS/Station Helper”;
}
2019-02-03 16:30:10 +0000: Video Device became inactive (FaceTime HD Camera (Built-in))
2019-02-03 16:30:18 +0000: user clicked ‘block’ for {
alertType = 1;
device = 2;
processID = 2393;
processName = “Electron Helper”;
processPath = “/Applications/Station.app/Contents/Frameworks/Station Helper.app/Contents/MacOS/Station Helper”;
}

I can block it with Oversight (https://objective-see.com/products/oversight.html), but I shouldn’t have to ;-).

Edit: Forgot to mention, video capable apps in the Station are Hangouts/Google Meet (seems to be ready all the time), Skype (rarely logged in until required). Seems like Station’s little helper is a little enthusiastic.

1 Like

:writing_hand: Camera is directly on at startup of Station!!

My problem is that at startup of station it directly uses the camera, although not have any communications. This feels like privacy breach. please repair this!.


:warning: Mandatory details

  • :gun: Trigger startup of Station software.

  • :boom: Issue Camera used directly without ever stopping.

  • :movie_camera: Explanatory gifs/pictures N/A

  • :desktop_computer: OS version iMAC, OSX Sierra 10.14.3

  • :gear: Station version latest 1.39.239

Same thing happening with me. It also seems to be turning on the mic as well. It’s enough to keep me from using the platform until it’s resolved. :slightly_frowning_face:

:writing_hand: Brief description of the issue

My problem is that the camera is constantly on when i have station open. Can you please fix this big brother issue?

regards


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

  • :gear: Station version

Has a solution been found? This is a big issue for me too.

:writing_hand: Brief description of the issue

My problem is that …
when i’m typing - typically when pressing the return key - Station will somehow launch Photobooth or Factime. I don’t know why it happens. I don’t know how it happens. What I do know is that this only happens with Station, not other apps.


:warning: Mandatory details

  • :gun: Trigger — Typing within Station

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — OSX10.13.4 (17E199)

  • :gear: Station version — Stationversion 1.41.1

Electron4.1.4

Chrome69.0.3497.128

Node10.11.0

v86.9.427.31-electron.0

@getstation/services0.28.0

I’ve been experiencing the same issue on Windows - the webcam started as soon as I logged into gmail. Signing out and singing back in fixed the issue, but this is an extremely worrying security vulnerability

Problem still persists, I know this is France and it is August but this is a serious security loophole - not a single response yet? I’ve had to log myself out and back in thrice today. Is anyone listening?

:warning: Mandatory details

  • :gun: Trigger — No clue!
  • :boom: Issue — webcam switches on automatically - are you spying on users?
  • :movie_camera: Explanatory gifs/pictures — NA
  • :desktop_computer: OS version — Windows 10
  • :gear: Station version — 1.45.3