Icon launcher

I had to uninstall and reinstall Station 1.5.1 because the launch icon didn’t work. When I tried to reinstall, despite having deleted ./config/Station, the application icon no longer appears. There is a solution?

2 Likes

Hello,

Same problem for me on Ubuntu 18.04, after lauching the 1.51.1 AppImage, the launcher doesn’t appear anymore.

1 Like

Hello community & Station Team !

This message, just to add that the icon disappeared too just after the upgrade to Station v1.51.1 on Ubuntu 19.04.

Installation :
Station 1.48.1 on Ubuntu 19.04 : Application menu bar icon →OK

Reproduction steps :

  • File > Options > “Check for updates” button
  • Download of the new version
  • Restart Station to validate upgrade
  • Icon not more available

Thanks for your hard work !

Best Regards !

in fact I have verified that the problem affects all new appimage format release applications. But there is a solution to solve the problem: the use of The Assassin Appimage Launcher. The debian installation file (bionic) for use with Ubuntu is also available. Once the package is installed, it takes care of the first launch, without needing to make the appimage package executable, to start the application in an extemporaneous or integrated way. If you choose the second option, the appimage package is moved to the “Applications” folder within your home, it is made executable, it is inserted in the menu with its icon. Appimage Launcher also allows, through contextual menu, to update and / or remove the chosen appimage. It works very well.

Thanks for this tip. I had the same problem, installed APpImage launcher, and the Station Icon is back, and I can favorite it again.

This solved my problem too! :smiley:

Thanks a lot!

I still have a problem and now the updates are not downloaded. Supposedly the download and the program closes but does not open again. When I open it manually, it keeps previous version

Have you had that problem using TheAssassin / AppImageLauncher?

No, I haven’t had this problem with TheAssassin AppImageLauncher for now. Just this evening I received an update from Station.

Oh! I checked for updates and this new version appears image

but when I quit to install the new version, the app does not open again. When I manually open the app, the previous version appears:
image

You are right. Also because the update should replace the previous release (1.51.1) with the current one (1.52.2) and this does not happen. I removed the previous version via Appimage Launcher and downloaded the next one. But this should happen automatically while, at least with my Ubuntu version, no update function appears in the context menu.