Gmail freezes when answering long emails / slows down while typing

:writing_hand: Brief description of the issue

My problem is that the Gmail app freezes for a while when I am answering an email inside a large thread. It comes back after a while and freezes again a little later. The CPU usage doesn’t seem to be specially high.
This doesn’t happen when using Google Chrome or Firefox answering the same email.
I have noticed this since I updated to 1.38.1. With the previous it didn’t seem to happen but I had it for just 1-2 days (I started using Station last week).


:warning: Mandatory details

  • :gun: Trigger — Answering a large email thread in Gmail

  • :boom: Issue — Gmail Freezes

  • :movie_camera: Explanatory gifs/picturesimage

  • :desktop_computer: OS version — macOS Mojave 10.14

  • :gear: Station version — 1.38.1

Same issue on my side. Email freezes when answering to a long thread. I have to switch to Chrome to answer long email threads. Didn’t notice it before, but the issue appeared twice in the last week since update to 1.38.1.

  • :gun: Trigger — Answering a large email thread in Gmail
  • :boom: Issue — Gmail Freezes
  • :movie_camera: Explanatory gifs/pictures Thread with 4 layers of emails, 116 paragraphs
    :desktop_computer: OS version — macOS Mojave 10.14.3
  • :gear: Station version — 1.38.1

Same here. Slow in app, even after reloading tab and app. In Chrome it’s fast. Maybe some integration is failing?

Since moving to 1.39.1 and later 1.39.2 I haven’t noticed this issue again. It seems to be fixed in the newest versions.

I seem to have the same issue on 1.39.2

Hey @juanpampliega, @Eugen_Gossen1, @Wout_Mertens, @andskli :wave:

There was indeed an issue with our spellchecker that lead to freezes in Google apps. This should be fixed in Station’s latest version (1.39.2) :partying_face: Could you update your Station and tell us if it’s been solved for you?

To update, just open the preferences (from the “Station” top bar menu) and click the “Check for updates” button on the right.

Hey there :wave:

I’m having a hard time reproducing this bug on Station 1.39.2. and gonna need your help :ambulance:

  1. Does it freeze completely or simply lags?
  2. Is the issue systematic or only appears from time to time?
  3. Does it occur only in Gmail or everywhere there’s a text input?
  4. Do you have a specific action that triggers the bug?
  5. How often do you restart your computer (on average)? Did you restart it recently?
  6. On which OS are you?

Thanks a lot for your answers.

My bad, still happens in 1.39.2

It only happens in GMail with large threads and I also think it only happens when I have people that user other email clients answer (Outlook I think).
Maybe it has something to do with the markup composition of the email?

  1. Freezes completely for a couple of seconds.
  2. Systematic with long email threads with non GMail users.
  3. Haven’t seen it popup elsewhere. I also use Slack, Trello, Keep, Calendar and Whatsapp.
  4. Answering an email.
  5. Haven’t restarted it recently but did restart Station and it keeps happening.
  6. Mac OSX Mojave with Dark Mode.

Is there any way for me to disable spell-check and see if it keeps happening. I searched for an option but didn’t find one.

Hey Georges,

I am on the verge of abandoning Station because of this bug. I noticed it first some time early this year (1.38.1 I believe). And it has remained consistently through the updates. I am on 1.40.1, and it is still there. Not easy to reproduce, but I will try to give you some info.

  1. It lags, but the lag can be very long (up to 15-20 seconds), so that you have the impression that it is frozen.
  2. The issue is systematic on some email threads. i.e. I can reply to a small thread without problem. and when I open a problematic thread, gmail will lag unbearably in station, so I need to switch back to chrome to answer.
  3. I noticed the freeze only in Gmail for me. But the lag is across accounts. I can open the same problematic thread in two different gmail accounts on station, and it will lag in both.
  4. Simply typing text is what causes the lag.
  5. Restarted the computer yesterday.
  6. OS 10.14.4

I suspect it is a visualisation issue of varying formats.

-> I tried to reproduce in an artificial thread (3 adresses exchanging, 20 replies, 1 attachment of 2 Go, 1 Gdrive link, 1 non gmail address), but this one stays fluid. So I am a bit at odds of what it is exactly.

-> I copied one problematic thread in a brand new email, and the issue appeared. The freezing became less and less long as I gradually removed attachments, images, formatting, length, layers.

Hope that helps. If you have any other ideas for how I can help to narrow down the problem, let me know.

6 Likes

I couldnt agree more! Im about to switch back to Franz. It is not as good but it never glitches out like this.

Literally 1/3 times i tap on the program, i have to wait a couple minutes for it to unfreeze.

Im using Mojave on a 15inch 2017 Macbook Pro Touchbar. Its a beast. No reason this shitty little app shouldnt be working.

Tried to force reproduce the problem but its too unpredictable.

I’m on a 2018 15" MBP Touchbar - and have started having the same issue. I am on the latest version of Station as well - and have configured 12 services in total. Next time this happens, I will shunt Station and move to the forked Wavebox - which seems to be producing nightlies and is also on the latest Electron, etc.

@Eugen_Gossen1 @Michael_Soussan @avijayr

Thanks a lot for your very thorough answers! We are working on improving performance at the moment and that might solve this issue but we are not entire sure. Could you send us a screenshot of your console when the freeze happen? (View > Developer > Toggle Page Developer Tools > Console). That would help us a lot!

:writing_hand: Brief description of the issue

My problem is that, ever since the last update (Version 1.41.1) Gmail crashes every 10-15 minutes. When I click in “Try Reloading” the whole Station application closes-


:warning: Mandatory details

  • :gun: Trigger Crashes by itself after a few minutes working

  • :boom: Issue Gmail crashes

  • :movie_camera: Explanatory gifs/pictures

image

  • :desktop_computer: OS version Ubuntu Linux 18.04

  • :gear: Station version 1.41.1

This is also still happening to me (v1.41.1) and the reason appears to be spellchecking still.

Is there maybe a way to disable spell checking? I don’t use it anyway…