Coda is buggy / not displaying properly


(Tom Avatars) #1

The issue I’m facing is:

When using any type of Coda document, the content and sidebar are not displayed.


Here’s the detailed report

  • Trigger: Just using Coda in Station.

  • Issue: Coda used to not work at all before 1.15. Now I can connect to it but the content and sidebar are not displayed, it’s a blank page. I tried to reload Station and restart with no result. Tried with a few documents, same result.

  • Explanatory gifs/pictures (we really need that :pray: ):

  • OS version: Mac Sierra 10.12.6

  • Station version: 1.15.0


Coda docs open in a new window
(Nathan R) #2

I’m having the same exact issue here.


(Chinara James) #3

Yea the Chrome version issue is fixed but the app is not working correctly. Same issue as the users above.


(Alexandre Lacheze) #4

@nigel do you have a hint on what could be the root issue of this — except from the outdated version of Chromium.


(William ) #5

Having the same problem on Window 10 as well


(Tom Avatars) #6

Now we have the Chrome compatibility issue back.


(Nathan R) #7

On 1.21.0 I’m having the same issue as the screenshot above. No content, no sidebar and a weird blank space in the upper left.

I’m on Sierra latest.


(Oleg Vaskevich) #8

Hi guys - Oleg from Coda here.

I actually stumbled upon this thread myself after running into the same issue, and it turns out that Station is still using an outdated version of Electron (the embedded version of Chrome used inside Station), but pretending that it’s running on a modern version.

In fact, if you take a look at the screenshot, Station is running v61 of Chrome but masquerading itself as running v67. What’s more, the “user agent” text doesn’t even hint that it’s coming from Station, so we actually can’t even detect on our end that this isn’t Chrome, leading to the broken behavior you see here.

Unfortunately, Coda relies on the security and rendering features of Chrome v65+, and thus there isn’t much we can do on our end until Station gets updated to use Electron v3.0 or later.