Can't launch / Station crashes: SQLITE_ERROR | Duplicate column name: manifestURL

✅released
(Jeff Burka) #1

:writing_hand: Brief description of the issue

After updating to 1.40.1, Station has a fatal error on startup with the message “SQLITE_ERROR: duplicate column name: manifestURL”


:warning: Mandatory details

  • :gun: Trigger — Open Station

  • :boom: Issue — Fatal error

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Windows 10 Home, version 1809, OS build 17758.4

  • :gear: Station version — 1.40.1

0 Likes

The application stopped running after updating to 1.40.1
Station(1.40.1) does not start on Windows
The application stopped running after updating to 1.40.1
New update from today keeps crashing
Fatal Error SQLITE_ERROR: duplicate column name: manifest URL
Station doesn't load up. Keep getting this Fatal Error
(Diego Sanchez) #2

Same for me. After updating to the last version I can’t open the app it promps Station Fatal Error, SQLITE_ERROR: duplicate column name: manifestURL.

0 Likes

(Alexandre Lacheze) #3

Hey there :wave:,

Thanks for reaching out!
“Resetting” your Station profile should solve your issue:

Tell us how it goes :wink:

1 Like

(Jeff Burka) #4

I did not want to reset Station, so I solved this the following way:

  1. Download DB Browser for SQLite: https://sqlitebrowser.org/
  2. Find your Station database. For me it was C:\Users\myUsername\AppData\Roaming\Station\db\station.db
  3. Open the database in DB Browser.
  4. Click on the servicesData table and click Modify Table, and rename the manifestURL column. For me there was no data in it. I renamed it to manifestURL_servicesData.
  5. Click Write Changes.
  6. Open Station. After it opens you will see there is a new manifestURL column in servicesData, so I think the problem was that Station was trying to create a new manifestURL column in servicesData when one already exists.

@Alexandre I think this should be an easy fix, and we can’t be the only two users with this problem.

4 Likes

(Kraig Lutz) #5

For me the manifestURL column that needed to be renamed happened to be in the activity table. It was also empty so I just renamed it to manifestURL_activity and Station was able to load.

0 Likes

(CarlUX) #6

It’s works but I had to re-config everythig (reset is not the best solution but… ok, thanks!)

0 Likes

#7

Station 1.40.1
Windows 10(1809)

The following dialog is displayed

Station Fatal Error
SQLITE_ERROR: duplicate column name: manifestURL

dialog

0 Likes

(Lester) #8

:writing_hand: Brief description of the issue

My problem is that …

Station does not launch on my Macbook Pro

Error message:

Station Fatal Error

SQLITE_ERROR: duplicate column name: manifest URL


Reinstalling does nothing


:warning: Mandatory details

  • :gun: Trigger — Launching the app

  • :boom: Issue — Fails to Launch

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — MacOS HighSierra 10.13.6

  • :gear: Station version — Newest downloaded (4/8/19)

0 Likes

(Michael Soussan) #9

:writing_hand: Brief description of the issue

My problem is that …ever since the new update on April 8th, my Station app keeps crashing…


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version

  • :gear: Station version

0 Likes

(Casey Podlucky) #10

I’m having the exact same problem. I have uninstalled and reinstalled Station and I continue to have this problem.

The error received is:
SQLITE_ERROR: duplicate column name: manifestURL

This occurs whenever the program is initiated. Station will not fully start and will shut down after the error is closed.

0 Likes

(Casey Podlucky) #11

This worked. Thank you! I had to rename the one in my Activity table for it to work. Oh behalf of the others, thank you for sharing this info!

0 Likes

#12

This started happening for me today on MacOS.

0 Likes

(DevBytes) #13

Hi @Sebastiaan

Where you able to resolve the problem?
If not you could try the next two options:
For the brave ones (Watch out to not change anything else except for the manifestURL column’s Name):

If you dont mind to reset your station you try this option:

Let me know if it helped :wink:

0 Likes

#14

Thanks, resetting my profile did help. But that is not a fix for the actual bug.

AFAIK I changed nothing to my Station settings. I updated & rebooted my Mac last night, on opening Station, it maybe did an update or something else went wrong.

0 Likes

(DevBytes) #15

The fix for the bug could be implemented in the next version of Station.
For now we just have to wait and see if they fix it :wink:
You can always check out Stations Public roadmap here:


This way you know what they are working on and what they have finished :slight_smile:

0 Likes

(Takeru Mizoguchi) #16

It does not start even if it reinstalls.
What should I do now?

dialog

0 Likes

#17

The same phenomenon occurred with the osx app.
So I deleted the file /Users/me/Library/Application\ Support/Station/db/station.db and was able to launch it.
Unfortunately, this way data is lost.
I expect this bug to be fixed for all users.

0 Likes

(Michael Soussan) #18

Wow guys. Ever since I installed the update the app has been awful slow to load and half the time I need to restart the program for it to function? Can I revert back to an earlier version cause right now this productivity tools has been terrible…please advise as I’m now looking for better competitors with more stability.

0 Likes

(Daniel Motzouris) #19

ffwfrw

I’ve uninstalling and re installation the app. Doesn’t work.

Anyone have any suggestions?

0 Likes

#20

Station team - What is the timeline to get this fixed?

0 Likes