Can't launch / Station crashes: "Segmentation fault (core dumped)" on Linux


(Matej Moško) #1

:writing_hand:Brief description of the issue

My problem is that Station doesn’t start at all. This is the first time I was about to try Station. When run in terminal, the error is

Segmentation fault (Core dumped)

when run with sudo, the erorr is a little bit more verbose

/usr/local/share/applications/appimagekit-browserx.desktop: warning: value “Station” for key “Comment” in group “Desktop Entry” looks redundant with value “Station” of key “Name”
Segmentation fault

Nevertheless, the app is not starting.


:warning:Mandatory details

  • :gun: Trigger Start

  • :boom: Issue The app doesn’t start

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version Ubuntu 18.10 beta

  • :gear:Station version 1.24


(Alex) #2

Same to me.
Ubuntu 18.10 64bits
Station version 1.25
Segmentation fault (Core dumped)


(Rich) #3

I’m having the same issue in 18.10 64-bit. Not quite sure how to debug or downgrade to an older version of Station and to try that.


(Rich) #4

Found prior version and same error on my system from 1.19.0 and up.


(Matej Moško) #5

I have tried 1.25 and segmentation fault is still happening. But I may have found a problem. The same situation is with atom editor (electron based as well) on 18.10. However they have already found a solution and in their beta the problem is solved. Electron has to be updated. Look here: https://github.com/atom/atom/pull/18012


(Matej Moško) #6

Still faulting on 1.25.1