Cannot add Moo.do

📦station-v1-15-x
✅released

(Jennifer Harris) #1

The issue I’m facing is …i’m unable to add Moo.do to Station.


Here’s the detailed report

  • Trigger: click “add Moo.do”
  • Issue: asks me to sign in with Google, I choose my Google account, hit enter, system sends me back to the sign-in page.
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Windows 10 Home
  • Station version: 1.0.11

(Justin) #2

I’m seeing this as well. I also end up with a blank window that has popped up in the background (or left over from the login?) that does nothing as well.

Here is a GIF. When the mouse goes off screen it’s because I’m clicking my google account in the popup. I bring the blank gray window mentioned in to show it also:


(Justin) #3

FYI, the grey box is still hanging around after several restarts of my machine. Haven’t uninstalled yet, to see if that fixes it in case I can help in any way while it’s in this state.


(Georges Abi-Heila) #4

Hey there :wave:

This should be fixed in Station’s latest version (1.15).
Could you update your Station and tell us if it’s been solved?

To update, just open the preferences (from the top bar menu) and click the “Check for updates” button on the right.


(Sean Gilbertson) #5

I’m having a similar issue in 1.25.1. When I click “Sign in with Google” for Moo.do, it opens a popup titled “authpopup#####” where #### equals a random number. However that box is completely blank white so I cannot complete the sign in process.


(Sean Gilbertson) #6

Fixed in 1.26. Thanks!


(Sean Gilbertson) #7

So Moo.do just did an update, which requires re-logging in. The issue mentioned above (where trying to sign in with google brings up a blank window) has come back.


(Jay Meistrich) #8

Moo.do developer (and Station user) here. We’re using Firebase’s signInWithPopup to sign in. Is that incompatible with Station? What can we do to make it work correctly in Station?


(Alexandre Lacheze) #9

@Jay_Meistrich thanks for digging into this!

Yes, Firebase signin and Electron seems to not be best friends.

I think the underlying issue is the management of popup window, esp. in iframe.

That being said, I was able to teak the configuration for Moodo (useNativeWindowOpen) to get it work and it will be released and working at next release.


(Jay Meistrich) #10

@Alexandre Great! We’re using useNativeWindowOpen in our Electron app too. Thanks for the quick turnaround!