App doesn't load / blank screen / white page / nothing is displayed (Gmail, OneDrive, WhatsApp, Slack, Missive, Messenger, TickTick, Google Voice ...)

📦station-v1-30-x
✅released

(Tevya) #42

:writing_hand: Brief description of the issue

Slack gets to the Slack loading screen, but then won’t go any further. I’ve tried reloading multiple times. Quitting and reloading Station entirely, and even removing and re-adding the Slack app. Nothing works. I can’t access Slack!


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — MacOS - latest stable

  • :gear: Station version — latest stable


(Tevya) #43

I think this was incorrectly merged. For one thing, it wasn’t giving a white screen. I would load the Slack loading screen with our custom quotes to show during loading. It would even show the loading indicator that would complete, but then the Slack loading screen would never give way to the actual Slack interface like it normally does.

I tried the reset application and reload this page options multiple times and it would not work. I removed and re-added slack multiple times (but it never had me login again). I even tried force closing it with the task manager. Nothing worked. I finally couldn’t waste more time waiting for Slack to work, so I completely removed Station and downloaded it and installed fresh. That fixed it for now. But I wonder if there’s some other bug here. Maybe more control (or a single option) to truly, completely reset an app would do it. But right now the option that’s available isn’t really clearing it, or I would have had to login again.


(Kaspar Manz) #44

I have the same problem as @Tevya. Since 1.29 (the “Use-Team-Logos-as-Icons” update), both my Slacks won’t load anymore, but are stuck at their loading screens, see below:

The console gives me the following output:


(Georges Abi-Heila) #45

Hey @xeophin, @Tevya, @Tetiiiana, @Alex_Wada, @stefano_scoponi, @Eliza_Morrison, @Shreeti_Badhani, @Hovl, @artthhh, @kspring, @stefan_ketola, @andrea_b, @Matthias_Posch, @Nathan_R, @lenstype, @Thomas_Hill, @Jordan_Krueger, @Ignat_Savkin, @LarsDR, @ashwanihere, @Christopher_Kummel, @Ian_Rodrigues_Porrat, @StuartB, @thanhpt, @gladely, @Jason_Ansley, @111111, @Justs, @imbrechtsjurgen, @Dany_Elementor, @kmor :wave:

This should be fixed in Station’s latest version (1.30.0) :partying_face:
Could you update your Station and tell us if it’s been solved for you?

To update, just open the preferences (from the “Station” top bar menu) and click the “Check for updates” button on the right.


(Kaspar Manz) #46

Slack is still not loading with 1.30.0, sorry …

(In my case it’s just Slack that’s not loading, everything else, like Google Mail, Google Drive, Gitlab, Notion, Hangouts, etc.) is loading just fine.)


#47

It looks like the blank screen is gone, but I can’t tell for sure because it’s doing this crazy strobe effect. I can’t even capture it in screenshot, it’s that fast. Love Station, but I’m not trying to have seizures! :camera_flash::camera_flash::camera_flash::camera_flash::face_with_head_bandage:


(Christopher) #48

Works for me :pray:

  • :desktop_computer: OS version — MacOS - 10.13.6
  • :gear: Station version — 1.30.0

(Kaspar Manz) #49

Okay, deleting the “Station” directory within “Application Support” fixed the problem, as in: Slack loads again.

But of course this meant having to add all my apps back in, which is frustrating.

Even more so since Station requires you to “Create an account” and won’t work without it, but then for some reason doesn’t remember the apps I added to my setup when I later log back in with the same account. Sorry guys, this doesn’t make any sense at all.


(Matthew S) #50

I think I am going to have to give up on this app. It has been months now and no updates have fixed the issue of apps not loading (stuck on "Wait while we load X. Even the Station App Store gets hung up!), or if I restart Station, it loads the start page, but nothing is clickable on the page.

I have tried: Closing all the processes, (which just made Station crash), removing and adding back the apps, (which is harder to do now with the latest update since the app store stopped working as well and reinstalling station.

I’ve had my fair share of bugs and glitches in new apps, but this is simply unusable. This needs to go back to Alpha.


(Sarahihulcy) #51

This is still happening for me in Gmail. It will actually even load the background theme of my gmail, but nothing else.


(Clark Wilson) #52

:writing_hand: Brief description of the issue

My problem is that the Complice app never finishes loading. Stuck at “Wait while we load Complice…”


:warning: Mandatory details

  • :gun: Trigger — I invoke the Complice app.

  • :boom: Issue — It gets stuck at “Wait while we load Complice…”

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — Windows 10 Home version 1803

  • :gear: Station version — 1.36.0

I removed the app from Station and re-added it. No change. I am able to access the app site complice.co in my browser without problems.


(Harry F) #53

Same for me but with Facebook Messenger.

White screen after login.


(Vladyslav Sitalo) #54

+1 Experiencing this with FB messenger


(Tony Xiao) #55

I’m having the same issue. Is there a way to completely reset station and start over?


(Clark Wilson) #56

My guess is that the Complice people changed their login sequence enough that the Station login code doesn’t work. It’s not a white screen, it’s just “I get stuck trying to connect to Complice.” Everything else is working fine for me.


(Jason Wong) #57

:writing_hand: Brief description of the issue

My problem is that my app turns into a white black view at the end of every day


:warning: Mandatory details

  • :gun: Trigger Normal usage, in full screen mode on my secondary monitor

  • :boom: Issue Automatically turn into a blank view after full day of usage

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version MacOS Mojave v. 10.14

  • :gear: Station version 1.36.0


(Malcolm Ocean) #58

Creator of Complice here (someone pointed me at this thread).

I did make a small tweak to the login page recently but I don’t think it would break anything (it was mostly a visual change, and mostly on mobile.)

I’m testing out station for the first time though and I can confirm Complice isn’t loading (same as what Clark describes). I’m not sure what I can do to help, since I’m not seeing any details or anything, but maybe some of the Station folks (@Georges?) can let me know if there is something for me to do!

Looking on my backend, I’m seeing a “Client Request Interrupted” error from the Heroku router, for a request for the homepage ("/") around the time that I open Station. Oh! And some request for the homepage is triggering a 301 redirect. My guess is that at least one of those has something to do with it, although I just tested that whole thing again and didn’t see either of those this time. :man_shrugging:

(I’m on Ubuntu 18.04, fwiw, with station 1.36.0)