After moving the Station AppImage, it cannot be found in the search anymore and has no icon

I’m using Ubuntu 19.04. After moving my station AppImage from the Documents folder to a different location, it has no icon in the sidebar anymore. It’s also not possible to find it with the search anymore. Any pointers?

I have the problem as well on Ubuntu 18.04. It has nothing to do with the moving of the AppImage, since I did not move it. Please fix this bug, since we cannot start the application unless it automatically starts on boot. The app cannot be found in the app gallery or in current processes.

If you are using the app from AppImage file you need to take care of the correct .destktop file.

Go to ~/.local/share/applications/ and look for either station.desktop or browserx.desktop. If there is not any, just create it on the base of any other desktop file. Point the path to the place where AppImage is, set proper icon path, etc.

If the app is installed, the default .desktop is in /usr/lib/station/browserx.desktop

1 Like

First, thank you very much for the reply. I’m a bit lost, I just started out on Linux and I’d appreciate a few more pointers.

I’ve checked ~/.local/share/applications/ and there is neither station.desktop nor browserx.desktop. There is a file called appimagekit-browserx.desktop. I’ve opened it and it links to the correct location of my AppImage. I have copied the file and renamed it as browserx.desktop, but so far there has been no change.

What do you mean when you say “create it on the base of any other desktop file”? And how do I determine the proper icon path?

Also, what do you mean with "the default .desktop is in /usr/lib/station/browserx.desktop"? I’ve checked /usr/lib/ and there’s no directory called station.

The name of the .desktop file doesn’t matter much. Open various desktop files and analyze the structure. It’s not complicated, for example:

Name= decides what name is shown in the start menu and what you can search
Exec= os the command that launches the program, most of the times the name of the app is the command, sometimes it’s a path to a bin file or some other file on the system
Categories= decides in which menu categories the app shows up
Icon= points to the icon of the app, installed apps usually have the name of the app and the icon is found, because it’s registered in system in other places, but you can point a path to the icon path so you can create your own icon, put it where you want and then point to it in this line, so if there is an issue with the default icon, just create it yourself
Comment= shows up in some menu entries as a description of a program

Most installed programs have .desktop files in /usr/share/applications/. You can copy any of those files to ~/.local/share/applications/ and tweak it. Some apps already do that, others don’t and use the file on root. If you have a file in your user folder it is used over the one in root. The same is with configs.

I use the installed version of station and it resides for me in ~/.local/share/applications/. If you use appimage, it won’t be there.

Appimages are awkward. They will work no matter where they are. Some will integrate with the desktop when you first launch it and that means: they create .desktop file. If you move the appimage, you break the paths that are saved in .desktop file so you need to update it to the new place.

If a .desktop file doesn’t exist you can create it manually. Just open any text editor and save the file as appname.desktop. As to the content you have to figure it out by checking other .desktop files.

Broken icons is a relatively frequent problem. I would download some station icon from the net, named it properly and then put a path to the file in .dekstop.

Just play with ,desktop files :slight_smile:

I’ll give this a try. I really appreciate the long reply!

What do you mean when you say you’re using the installed version of Station? Are you on Linux? Because the only thing I can find is the AppImage

I’m using Manjaro. Station is open source so it always can be installed on any Linux system via compilation from source. However, on Arch based systems we have access to AUR so we can find most apps there. AUR offers recipes that can be used to install programs.

When I check the source for such AUR recipe I see:

https://github.com/getstation/desktop-app-releases/releases/download/${pkgver}/Station-${pkgver}-x86_64.AppImage

So this is an install from AppImage, so my guess is, it’s unpacked, got rid of dependencies and installed the native way by the PKGBUILD recipe.

The pro of such installed format is that it takes less space, less system resources and it will be automatically updated by package manager, unlike AppImage.

There are some small cons too. Latest update from AUR was ahead with dependencies on Manjaro. Since I am on testing branch, I got those dependencies after few days, but someone on stable branch would have to wait few weeks. Of course there are workarounds for it and such dependency issues happen rarely so this isn’t really an issue.

If you want to know what is the outcome of such dependency mismatch is that after Station update that needs newer libraries won’t work till system won’t update to those version of packages. You can always roll the app back to older version or switch the branch, update system to get the app working.of the app that work

I’ve tried all these solutions and nothing worked. I’ve created files called browserx.desktop and station.desktop and appimage-browserx.desktop and appimage-station.desktop in both ~/.local/share/applications/ and /usr/share/applications/, nothing has worked.

Any other ideas?

I don’t know what changed, I tried it now and it worked. Thanks!