"Add apps and extensions" does not work / is blank

:writing_hand: Brief description of the issue

I have added a custom app which I then tried to delete. It was not straight forward, so I tried to right click on it and clicking on “reset this app”. UNfortunately this broke the whole “add apps and extensions” page


:warning: Mandatory details

  • :gun: Trigger:
    right click on custom app -> reset this app

  • :boom: Issue:
    Add app page is broken
    Error message: SequelizeValidationError: notNull Violation: activity.resourceId cannot be null

  • :movie_camera: Explanatory gifs/pictures:

  • :desktop_computer: OS version:
    MacOS Mojave v10.14.5

  • :gear: Station version:
    MacBook Pro 13-inch, 2017

Hi @Anzor_Asadov!

Thank you for reporting this bug. We are working on it and it should be fixed in the next update.

Keep in touch!

Hello @Anzor_Asadov,

A new update is available! Station 1.50.1. In this one we fixed the fact that the App Store would be blank after reseting the app.
Upgrade your Station, reset again your App Store by doing a right click and “Reset Current Application”, then you should see your store again.

Tell us if it worked for you!

Hi @Maud!

Thanks! It worked. With one little correction:

Right clicking on the app store didn’t show the “Reset current application” option. I had to do it via “Help -> Reset current application”

Best Regards

1 Like

Hi @Maud,

Thanks for your answer on this issue.
Could you, please, ask the dev team to update the downloadable AppImage package for Linux user, so they can test the new fixes ?
Your website is still showing a difference between Windows and Linux binaries :

Thanks a lot for your help !
Best Regards !