A grey popup / blank window / empty screen appears on Station launch (and can't be closed or resized)

📦station-v1-30-x
✅released

(Alexandre Lacheze) #25

In Station version 1.20.0, we made some improvements regarding the apparition of grey-window.

@Flant @Sam_Adams @kaaist @KinahB90 @CyanideCupcake:
Could you please try again and let us know if the problem still occurs. :pray:


(Sharmaine Tan) #26

So I opened it and now the app doesn’t load in that new window. I cannot close it either because the “open, minimize, close” buttons don’t appear. And when I minimize my main Station Window, I cannot find that “window” like other apps do because it doesn’t seem to detect multiple windows open.


Here’s the detailed report

  • Trigger: Opened a new window for an app separate to WhatsApp
  • Issue: Cannot close the window, it exists even after restarting Station. When I minimize the main Station Window, it cannot be found because the other Window is still open.
  • Explanatory gifs/pictures (we really need that :pray: ): 10%20AM
  • OS version: Mac OSX
  • Station version: 1.11.2

(Phil Leroy) #27

:writing_hand:Brief description of the issue

After upgrading to 1.23.0 (macOS High Sierra), there’s a outsider grey window which I can’t close or minimize.
Seems like a bug as this grey window has no functionality at all.


:warning:Mandatory details

  • :gun: Trigger When I open the Station 1.23.0

  • :boom: Issue Undesired grey popup/window in the background

  • :movie_camera: Explanatory gifs/pictures
    24

  • :desktop_computer: OS version — MacOS High Sierra (10.13.6)

  • :gear:Station version — 1.23.0

This seems to be a regression as I was not facing this in previous versions.
The workaround proposed in another thread here works as well, which is focusing in the grey window and then Window > Close.


(Alexandre Lacheze) #28

Thanks @pleroy for the report!

After restarting Station, does the issue occure again?

If so, could you please:

  • focus on the grey window, open de Developer Tool (View > Developer > Open Station Developer Tool), and take a screenshot of the Developer Tool
  • open the Process Manager (View > Open Process Manager), make sure to scroll right to display the column Webcontents URL and take a screenshot

Add the screenshot to this thread!

Thanks! :pray:


(Skyler Katz) #29

Hello @Alexandre,

I have tried restarting Station, as well as re-installing Station, but still get the grey window.

Here are the screenshots you requested.

Thanks!


(Alexandre Lacheze) #30

@skylerkatz It seems like of your app has been detached and struggles being loaded. That’s some bug we are working on.

In the meanwhile, could you check your apps and figure out which one is detached. You should see this kind of icon on the detached one. Click on it to reattach:

38


(Darren Lock) #31

I have the same grey window, but having checked, none of my apps have that icon next to them


(Skyler Katz) #32

@Alexandre I checked all of my apps and none of them are detached.

Anything else you want me to investigate?


(Dyrc Mc Leod) #33

I am having the same problem and have been for a while. I noticed the last post was 6 days ago and wondering if there was a fix yet.


(shoeboxdnb) #34

Same problem here… quite annoying.


(Kenzy Desmet) #35

:writing_hand: Brief description of the issue

When I open Station, I get the app which is perfectly working but another blank page is opened as well.
You can’t close it and it does absolutely nothing.
Is there a solution for this?


:warning: Mandatory details

  • :gun: When I open ‘Station’

  • :boom: I get the normal station page, but a blank page as well

  • :movie_camera: 03 12

  • :desktop_computer: Mojave

  • :gear: 1.26.0


(Stanley Suwantika) #36

:writing_hand: Brief description of the issue

My problem is that whenever I access my Mac’s “Mission Control” or F3 button shortcut or swipe 3 fingers up -> to check my running apps, I noticed that Station app is opening 3 apps at once, the first app is the working Station apps, and the other 2 apps are a transparent window that has nothing on it… Here I give you the screenshot of my mac windows… I’ve restarted my laptop, nothing works… I’ve restarted the apps, nothing works… I’ve installed the newest version, nothing works too… Please help me because this is a bit annoying to see… Thank you very much…


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures00%20am 01%20am

  • :desktop_computer: OS version — Mac OS High Sierra 10.13.1

  • :gear: Station version — Station version 1.22.0, Electron 2.0.2, Chrome 61.0.3163.100, Node 8.9.3, v8 6.1.534.41, @getstation/services 0.21.3


(Alexandre Lacheze) #37

@stanley_suwantika @Kenzy_Desmet @shoeboxdnb @dyrcm @Darren_Lock @skylerkatz @pleroy do you still have the issue with latest version of Station (1.28.1)? We made several fixes that could have an impact.

If not, please precise:

  • Station version
  • your OS version

(Skyler Katz) #38

The issue is indeed still happening.


(Arfeng Work) #41

:writing_hand: Blank Window Cant Be Closed

My problem is that i have a blank white window that cannot be closed. Its just appear to be empty and i cannot do anything with it.

I tried to close the app and open it again but it still there. …


:warning: Mandatory details

  • :gun: Trigger

  • :boom: Unwanted Window

  • :movie_camera: Explanatory gifs/pictures 54%20PM

  • :desktop_computer: OS version Mojave 10.14—

  • :gear: Station version 1.28.1 —


(Georges Abi-Heila) #42

Hey @arfengwork, @skylerkatz, @stanley_suwantika, @Kenzy_Desmet, @shoeboxdnb, @dyrcm, @Darren_Lock, @pleroy, @Sharmaine_Tan, @Flant, @mzphitt, @Sam_Adams, @kaaist, @KinahB90, @CyanideCupcake, @datnt, @dayraarrieta, @Ravi_Madabhushi, @KCain, @Jordigg, @mcodazzi, @William_Chou, @moteur.diesel, @nicondev, @JustinJ01, @sydney :wave:

This should be fixed in Station’s latest version (1.30.0) :partying_face:
Could you update your Station and tell us if it’s been solved for you?

To update, just open the preferences (from the “Station” top bar menu) and click the “Check for updates” button on the right.


(Jordigg) #43

Few weeks ago I followed a fix on this thread and didn’t see the grey windows appear again. Thanks for fixing.


(Dat Nguyen) #44

I haven’t seen this blank window for quite a long time (around 2 months I guess), so thanks to the team for fixing this. Please keep it up.