404 error / URL not found / something is not right on Google Calendar, Google Drive or Google Inbox

✔️workaround
⚙️in-roadmap

(Michelle Appleberg) #21

Happy to see you also using Station! Great minds think alike! :slight_smile: My team and I love Station and have the primary bulk of our tasks connected in there.


#22

The issue I’m facing is:
Google Inbox is not loading on my second google account. Works well with first one.


Here’s the detailed report

  • Trigger: open the second Google Inbox app
  • Issue: app doesn’t load > error 404
  • Explanatory gifs/pictures (we really need that :pray: ):image
  • OS version: Win 10
  • Station version: 1.15.1

(Gavin) #23

What happens when I try to open a new page in Google Drive:
35%20PM
Using existing pages I have for Google Drive works. Sadly can’t open a new page :frowning: Hope this issue gets resolved soon

Here’s the detailed report

  • Trigger: Add new page under Google Drive
  • Issue: Opening a new page in Google Drive leads to an error
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Mac OS X
  • Station version: 1.16

#24

The issue I’m facing is:

Google Inbox is not loaded, I am getting a 404 error page:

42%20PM

I’ve tried removing and re-adding it, but no luck.


Here’s the detailed report

  • Trigger: Install Google Inbox and click to view it
  • Issue: Getting a 404 error page
  • Explanatory gifs/pictures: Attached
  • OS version: MacOS 10.13.5
  • Station version: 1.15.0

(Alexander Volodin) #25

The issue I’m facing is: I have 404 error in gmail tab

in GMail tab I have only error message.

  1. That’s an error.
    The requested URL /mailvolodin@gmail.com/ was not found on this server. That’s all we know.

Here’s the detailed report

  • Trigger: I think maybe because my email has a digit number 4 in the begin my email.
  • Issue: in GMail tab I have only error message.
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: Mac OS high Sierra 10.13.4
  • Station version: 1.17.1

(Rajiv Kolluru) #26

The issue I’m facing is:

  • Whenever I switch back to calendar after a while it either shows a blank page or 404. Usually I remove the application and re-add as a workaround but today that isn’t working as well. Neither is reset current application option.

** Explanatory images**

  • OS version: MacOS High Sierra V10.13.6
  • Station version: version 1.21.0

Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version:
  • Station version:

(Luciano Capitanio) #27

:writing_hand: Station doesn’t load Gmail properly

My problem is that Station doesn’t load Gmail properly and issues the following error message:
Something’s not right.
We’re having trouble connecting to Google. We’ll keep trying…
Errors: 101


:warning: Moreover, when I try to select any item in Gmail nothing happens!

  • :gun: Trigger

  • :boom: Issue

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: Windows 7

  • :gear: Station version 1.26.0


(Gustavo Adolfo Bravo) #28

I hope this is the right place to ask the following questions (sorry if is not)
Is it common for a message like this to come out constantly?
“We can’t load Gmail… Try reloading.”
It happens in all apps.
As this

de9a39df2982d383ed41386bcadba5b6b89d76da_1_690x388


Here’s the detailed report

  • Trigger:
  • Issue: reloading
  • Explanatory gifs/pictures:
  • OS version: OS X 10.9.5
  • Station version: 1.0.8

(Luciano Capitanio) #29

Dear all,
hope this community will find a fix for this issue because this app could be great.
Unfortuntely, at the moment it is not usable at all.
Anyway, thanks for the great job.
Luciano


(Ali Shafai) #30

:writing_hand: Brief description of the issue
My problem is that …
Google Inbox doesn’t load for me.


:warning: Mandatory details

  • :gun: Trigger
    Simply adding the app.

  • :boom: Issue
    Leads to a 404 Google page.

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version
    10.14

  • :gear: Station version
    1.26.0


(Derek Lakin) #31

:writing_hand: GMail doesn’t finish loading

My problem is that when I switch to the GMail app and even after reloading the page it gets to the “Loading GMail” screen with the progress bar almost at 100%, but not quite.


:warning: Mandatory details

  • :gun: Trigger Switch to GMail app and reload page.

  • :boom: Issue GMail won’t load

  • :movie_camera: Explanatory gifs/pictures gmail

  • :desktop_computer: OS version Windows 10 version 1803 (OS Build 17134.345)

  • :gear: Station version 1.26.0


(Evan Marcus) #32

:writing_hand: Brief description of the issue

My problem is that …

When I try to use the Google Calendar page in Station, I get a 404 error. I uninstalled and reinstalled it, and got the same results. Other apps appear to work normally.


:warning: Mandatory details

Electron3.0.5

Chrome66.0.3359.181

Node10.2.0

v86.6.346.32

@getstation/services0.23.0


#33

I just started getting this issue after we migrated to a new Google account. Like everyone else, I now get 404 errors and the URL is appending my username. (Which is incorrect for Google URLs)

The “fix” that others ( I’m looking at you, Point-Of-Destruction ) have suggested, either navigating by clicking the Google logo or opening a developer console, is a workaround and not an actual fix, as you will need to do this on several applications every time Station loads.

I even tried completely deleting my profile (rm -rf ~/Library/Application Support/Station) and starting from scratch to no avail - the problem persisted.


#34

Hey guys, registered here since I got it working with an alteration of what was suggested and I’d like to share it for the record.
First go to any broken google service, for example calendar.
open the dev console (ctrl-shift-i), go to console
paste the following:

this.document.location = ‘https://www.calendar.google.com

confirm, it gave a new error message
now paste

this.document.location = ‘https://calendar.google.com

it will NOT work if you go with the last one right away for some reason, but doing the www first and remove it second worked for our company.
cheers


(Ahmad B) #35

:writing_hand: Brief description of the issue

My problem is that my drive was showing up empty (i.e. the navigation showed but no content loaded). When resetting, the server can’t connect. The weird thing is that it works just fine from chrome or Safari, but won’t load through station.


:warning: Mandatory details

  • :gun: Trigger — loading drive account

  • :boom: Issue — content won’t load, when reseting current application I then see the image below

  • :movie_camera: Explanatory gifs/pictures

24%20PM

  • :desktop_computer: OS version — Mojave 10.14.12

  • :gear: Station version — 1.36.0


(Devansh Sharma) #36

Great solution. Thanks, that works!


(Salem) #37

I’m having issued with Drive. Updated to the latest too.

Regular Drive account works, but if I open a second tab/page, it won’t work and give a 404.

The GSuite Drive doesn’t work at all.


(Vishnu Rachakonda) #38

Same issue with 404 here. Getting a URL not found, even after changing user accounts (which seemed to be tied to the issue earlier).


(David Gobert Cézanne) #39

Works Perfect!!! Thanks


(Pepijn Van Manen) #40

I had the same issue: Google apps work perfectly with my primary account, but since a week or so it returns a 404 if I try to access it with a secondary account. As I understand, this is because Station accesses the different accounts using the URL https:/ /appname. google. com/u/example@gmail. com/. These URL’s don’t seem to work anymore. The URL’s that use the structure https:/ /appname. google. com/u/n/ do still work, where n is a positive integer. I.e. the first Drive account you logged in with is accessible with https://drive.google.com/u/0/, the second is accessible with https:// drive. google. com/u/1/, and so forth. (don’t mind the spaces, the forum doesn’t allow me to post more than 2 links…)
So, as a workaround for secondary accounts, you can use the console tab in the page developer tools to navigate to your secondary account like this:

this.document.location = ‘https://www.drive.google.com/u/1/

The same works for Calendar, Keep, etc. The only thing I can’t seem to figure out is to change the default page when the app loads to that URL. Does anyone know the command for that?