404 error / URL not found / something is not right on Google Calendar, Google Drive or Google Inbox

⚙️in-roadmap
✔️workaround

(Biart Jeff) #1

Hello guys,

First, thanks for this awesome product :).

I used to be logged with my former company Google account to Station.
I got a new job, so this G account got erased.

I connected my new Gmail account, and all apps switched properly except for GDrive.
I can’t access it on Station I get the 404 error.

I tried to switch on/off my former and new accounts in GDrive parameters on Station. Tried also to restart the app (double clicking on the icon) and uninstall/reinstall the app, and it did not work.

Could you Erase my Account/session so I can create a new one?
thanks,
Jeff


Here’s the detailed report


404 error on Google Drive
Can't access Google Calendar-- 404 popup!
Google Inbox Bug?
Google Inbox extension not working
Inbox and Calendar aren't working for me
Multiple Google Drives
Google Inbox - 404 error
Can't login to GDrive
Google Calendar not working
Google Drive and Calendar not working
Gmail integration is not working
Google Inbox is not loading, getting 404 error page
Error in Gmail tab
Google Calendar doesn't load
Station doesn't load GMail and Drive properly
"We can’t load Gmail… Try reloading."
Google Inbox
GMail Won't Load
Google Calendar is giving me a 404
Opening a new page in Google Drive leads to an error
Google inbox secondary account error 404
(Gradbase Limited) #2

I am attempting to use a Google Drive tab. I have added my account details correctly, but when I try to access my drive a 404 is raised. The Drive tab is trying to access the URL: https://drive.google.com/drive/u/contact@gradba.se
This persists when I remove it and add it back to my Station again.
I am attaching a screenshot to help you investigate what could be going wrong. I was going to upload another one but this forum will not let me.

OS: MacOS High Sierra
Station Version: 1.0.8
Thanks for your support.
Alberto48![41|690x421]


(Gradbase Limited) #3

Here is my second screenshot.


(Douglas Rogers) #4

@Gradbase_Limited I was having the same issue. When I signed into ALLL my Google accounts that are connected, I was able to access Google Drive properly. Hopefully that helps you out.


#5

This happened to me as well. Luckily, I managed to fix it! Here’s how:

  1. On the 404 page, the Google logo actually links back to the Google Search homepage! So click on that.
  2. In the Google Search page that comes up, search for “Google Drive”
  3. Go to the “My Drive” link in the search results
  4. Done! :smiley:

Hope that helps!


(Philippe Laval) #6

The issue I’m facing is

Error on both Google Drive and Calendar.

Url are:
https://calendar.google.com/calendar/b/philippe.laval@gmail.com/r
https://drive.google.com/drive/u/philippe.laval@gmail.com

I get this: https://www.evernote.com/l/AAKxhnX3n1FO6r8tIMm2CveUvy8QiZwh_fk


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version:
  • Station version:

(Sam R) #7

Still facing this issue? It’s a pretty easy fix here you go. I’m surprised no one chimed in.

Menu -> Page Developer Tools -> Click on console ->

then type the text below for calendar, and change calendar to drive for GDrive, etc.

this.document.location = “https://www.calendar.google.com” and press enter

You’re welcome :slight_smile:


(Philippe Laval) #8

Great idea! The correct syntax is : this.document.location = ‘https://drive.google.com


(David) #9

Google calendar app is not working on my side with my Google Business suite account. :slight_smile:

See screenshot below

21


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: macOS 10.13.3
  • Station version: 1.6.0

(Samuel Masson) #10

The issue I’m facing is I can’t login to GDrive in Station.
I was facing the blank page so I wanted to try to delete GDrive App and re-add it but now I can’t login as it shows a 404 error page from Google.
Thanks in advance :slight_smile:


Here’s the detailed report

  • Trigger: Connect GDrive
  • Issue: 404 error - not possible to connect to my account after the authentication steps
  • Explanatory gifs/pictures (we really need that :pray: ): 39
  • OS version: Mac High Sierra
  • Station version: 1.7.2

(Steven) #11

The issue I’m facing is …

After the most recent update, google inbox is giving me a 404 error. The rest of the services work, google calendar, drive, but not inbox. Same error for all my google accounts.


Here’s the detailed report

  • Trigger: Update to latest verst
  • Issue: Google Inbox 404 error
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version: 10.13.3
  • Station version: 1.7.255%20PM

(William Mead) #12

The issue I’m facing is …

I have multiple instances of google drive. Some how they got disconnected (I think through a reboot of my system), and now they come up as a 404 page. I can’t seem to get rid of them or get them to log back into their appropriate accounts.

Even if I can get rid of them, it is annoying to have to add them all again.


Here’s the detailed report

  • Trigger:
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
  • OS version:
  • Station version:

(Raff Mars) #13

Hi! I tried to configure both my Google Inbox and Calendar apps but after I logged in I received a 404 error. At first, I thought it was a problem from Google but I can sync my Gmail and drive without a problem.

image

Station version 1.7.2
Electron 1.7.8
Chrome 58.0.3029.110
Node 7.9.0
v8 5.8.283.38

MacOS Sierra 10.12.6


(Stephane K) #14

Keeps wanting to go to https://inbox.google.com/u/. Which generates a 404. The correct URL seems to be (simply) https://inbox.google.com/

Perhaps this works if your email is @gmail.com but this is a custom domain name (i.e. using Google For Business or whatever it’s called these days)

Easy fix?


(Sam R) #15

This is the fix.


Guys this issue has been tried and tested and here is the fix, please read up the conversation and you will find it again there too but I will write it.

Scroll your mouse to the top of your screen on the menu bar, click ‘View’ > Developer > Toggle Page Developer Tools > Click on ‘Console’ Tab

Here you can execute commands, just like a command line except now you can control your page.
Yes that is correct. You can, just like your terminal or command prompt, execute commands to go to specific urls within your browser.

For Calendar
For G-Drive
For ANYTHING
It’s the same command with different urls, depending upon which url you’re trying to go to.

this.document.location = 'https://www.calendar.google.com'

and press enter

Now if you wanna go to Google Drive instead of Calendar, type in the regular google drive/whatever service url you’re trying to get at.

It thinks the url it’s currently trying to go to ends with a /u/ or /r/ and that’s what’s confusing it, so you give it a new url to go to and it will permanently go there from now on.

You’re welcome :slight_smile:


(Sam R) #16

Update

This fix may not work well anymore.
If you want the correct fix:

  1. Google 'How to navigate to another url + developer tools + console"
  2. Post it here.

(En) #17

The issue I’m facing is:
Station won’t display google calendar for me at all. :frowning: I’ve tried to:
-restart Station
-updating station to the newest version
-deleting and reinstalling the Gcal app within Station

and I keep getting a 404 popup…
Help!!!


Here’s the detailed report

  • Trigger:

  • Issue:

  • Explanatory gifs/pictures (we really need that :pray: ):
    59%20PM

  • OS version:
    High Sierra
    10.13.4

  • Station version:
    1.13.1


(Kosta) #18

I logged in Station for the very first time using my regular Google account. Gmail integration shows up in the side bar, but is not opening (see screenshot)
My Gmail address starts with a number (see screenshot), perhaps this may be the cause.


Here’s the detailed report

  • Trigger: Log in to Station with my google account and open Gmail sidebar item.
  • Issue:
  • Explanatory gifs/pictures (we really need that :pray: ):
    image
  • OS version: MacOS 10.13.3
  • Station version:
    Stationversion 1.8.2
    Electron1.7.8
    Chrome58.0.3029.110
    Node7.9.0
    v85.8.283.38
    @getstation/services0.11.0

(Michelle Appleberg) #19

Station will not connect with Inbox… see below.

image


(Erik Dana) #20

still having this issue :frowning:

I click com the google logo and then search inbox, it works but it’s a workaround.