1Password not working / not authenticating / wrong credentials / CLI is out of date

🛠working-on-it
⚙️in-roadmap

(Joel Gratz) #21

Glad to know that seems to be the case with others. I hope Station can make a fix on this. Must relate to how the CLI passes the info to 1password.


#22

I have mixed feelings about an unofficial 1Password service in general. While it’s very convenient, the risk associated is scary. While Station is a great app, I don’t have the same level of trust in their security infrastructure as 1Password’s.

I would highly recommend that people think twice before sharing their domain/user/key/password on any external service.


Station 1.17.0
(David Stamm) #23

I wish I saw this thread before I signed up for 1password only to find out it doesn’t work with station. I don’t see any status updates from Station, only users. What is the status?


(Joel Gratz) #24

David,
In my testing it should work, it just doesn’t work if you have spaces in your master password for 1password.

Joel


(Georges Abi-Heila) #25

Thanks @Joel_Gratz for the insight!
That’s seems like a good lead, we’re gonna investing the “spaces in Master Password” issue.


(Bobby Sciortino) #26

I just connected my 1password account to station with no problem. However, I tried logging into dropbox and it only fills the username/email but not the password. Very strange. The same credential works flawlessly in the browser.


(Luis Cacho) #27

Same issue here on a Ubuntu box.

Just adding that I’m using the standard login URL: my.1password.com

Regards.


(Cl Ark) #28

I solved it by using KeeperSecurity.com instead.


(Harminder Singh) #29

Hi George, any update on this please? I am getting the same error invalid credentials. I just switched from wavebox to find this doesn’t work.


#30

I’m just not able to get 1password to load. I never get a prompt to login using 1password. Is there any way to force 1password to work inside a given app? In my browser I always have an extension to click and fill in fields, but there doesn’t seem to be anyway to trigger the 1password integration so I’m left just using the mac app and copy/pasting in credentials.

I’m currently using version 1.30.0 of station but this has been ongoing. I think I got the 1password prompt maybe twice since installing.


(Satish Chandra B K) #31

Hey there,

Version 1.34.1
Mac Book Air
Mac OS: 10.14.2

Just keep getting a loading page(Screenshot attached), when I try to access 1password for fetching the stored accounts to sign in.


(Raphael) #32

Same issue with 1password: I’ve got the message wrong credentials. This is a must have to be able to continue to work with Station for my company.


(Jeremy Cox) #33

:writing_hand: Brief description of the issue

My problem is that …getting email notifications from 1Password that the CLI is out of date. My local 1Password is up to date, so I believe it has something to do with the authentication integration on Station backend


:warning: Mandatory details

  • :gun: Trigger — Every time I re-login to an app using 1Password integration, I get an email notification from 1Password that I should update

  • :boom: Issue\ 128x128
    Hi Jeremy. You recently signed in to your 1Password account on “Jeremy-Coxs-MacBook-Pro-3.​local” using a version of 1Password CLI (41001) that is out of date.

Please keep 1Password up-to-date. It’s free, and doing so will ensure you continue to have the best experience. To learn more, see:
https://support.1password.com/update-1password/

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — MacOS 10.14

  • :gear: Station version — 1.35


(Isaiah Franco) #34

I’m experiencing this same issue.


(Valery Kharshats) #35

Looks like 1password doesn’t require the domain for login anymore.


I see a good potential in Station however 1password autofill doesn’t work for few months.
It’s sad however I can’t recommend a product with such problems


(Joel Gratz) #36

Georges, any progress on figuring out why this doesn’t work? Is it indeed an issue related to spaces? Can it be fixed?


(Ivana Di Carlo) #37

:writing_hand: Brief description of the issue

My problem is that I’m typing the correct credentials (I copy and paste from the 1password app) but I get a wrong credentials error.


:warning: Mandatory details

  • :gun: Trigger — I insert credentials to connect my 1password account

  • :boom: Issue — I get a wrong credentials error even though the credentials are corrext

  • :movie_camera: Explanatory gifs/pictures

  • :desktop_computer: OS version — macOS Mojave 10.14.2

  • :gear: Station version — 1.36.1


(Hershy Goldberger) #38

Same Issue here. Need this to work!